Xperia X bricked because of aborted update please HELP

Hello,

I tried to update my Xperia-X with new sailfish x software version, but I put the on/off button by mistake. After that, the phone stucks on Sony-Logo when booting up.
I tried to flash sailfish x again, but my Computer says, no fastboot device is connected.
Can anyone help me please?

Just a suggestion: Booting with Volume up again? See the section 4.3 on recovery mode here:

Did you reboot your computer?

thx for your reply!
I rebooted PC again and after that I tried to enter fastboot mode (Volume up, then connection to pc) → blue light on phone is on, but the PC doesn’t recognices any phone or fstboot device :frowning:

In my device manager, it says “the device cannot be started”. Drivers are installed properly. Maybe my phone is bricked permanently?

Ok, I solved it. I tell, how it worked, in case other users have the same problem:

  1. Download Xperia Companion from sony homepage
  2. Install it, let it install ANY drivers
  3. the PC now recognises the phone in fastboot mode.
  4. flashing sailfish x :slight_smile:
4 Likes

Congrats. Have fun with your device.