Xperia Tama port: 4.3.0.12 release

This is to announce 4.3.0.12 SFOS update for Xperia Tama devices: XZ2, XZ2c, and XZ3. Please read release notes and description below before update.

The only major port specific change was an adjustment in OBS project organization. For users, it is mostly invisible. Exception is OTA update from older scheme to 4.3.0.12. The update requires few extra steps which have been made as convenient as possible and are described in dedicated HOWTO. As soon as these steps are done, proceed with the regular OTA instructions.

At the moment of writing (2 Dec 2021), only OTA has had a limited testing. So, early adopters, please report how it went. If someone preferred to flash the image, please report as well. For those wishing to be on the safer side, wait till more users would have a chance to test the release.

This release marks 2nd anniversary since the first public Xperia Tama Sailfish port release. Public releases started on 24 Nov 2019 with 3.2.0.12-alpha1. So, enjoy the occasion.

14 Likes

Thanks a lot, what exactly changed at the kernel?

In 4.3.0.12: got updated to 4.14.254. Not that you could see that from the package name, unfortunately.

Other than some messages related to ofono (some engine, technology whatever thing) during the upgrade the process went smooth. Will test and report any issues.

Thanks a million :slightly_smiling_face:

Edit:
WOW and it seems i can login to my banking website with whatever was fixed in the browser. That is HUGE for me. (other than password management which is another story all together)

3 Likes

anybody else who’s upgraded having trouble with sound ? I can’t get pulseaudio to start…

defaultuser ~ ➜  systemctl --user restart pulseaudio

gives
Job for pulseaudio.service failed because the control process exited with error co de. See “systemctl --user status pulseaudio.s ervice” and “journalctl --user -xe” for d etails.

devel-su journalctl --user -xe

gives

no entries

and
systemctl --user status pulseaudio.service
gives

Unit pulseaudio.s.service could not be found. lines 1-2/2 (END)

I tried
devel-su zyppen in -f pulseaudio
and it was successful, but didn’t fix.

I have pulseaudio working fine, pulseaudio.service available and running. Opposite to your commands. What has happened on your device is hard to tell. However, knowing that you had also some strange permissions issues which I haven’t seen myself nor reported by others, I suspect that something is off in your config.

1 Like

I updated by OTA from 4.2, no problems, sound works and thanks to ApB for the hint about banking, I can log in too…although some pages don’t scroll properly. The only problem I had with 4.2 was the camera not opening correctly first attempt, usually I had to close it and start again…this seems to be fixed, fingers crossed. Thanks again to Rinigus et al for this great port.

1 Like

Got it - permission issue again. I had chmoded 0777 to solve previous issue, but seems like ~/.config/pulse needs 0700

*I like!*great port !!

Updated today. Everything looks to be working as supposed to be. Many thanks for the hard work!

Noted that dnsmasq has to be disabled in order to get waydroid running, as instructed on the sailfishos-open/waydroid github page.

1 Like

I’ve started getting messages from openrepos and jolla store about “critical problem” and “rpm exception”. The jolla store says I have no apps installed. Chum shows no packages and when I try pkcon refresh I get ‘rpm exception’. Apart from that, everything works as normal! Camera works every time too.

I wonder if your storage run full during update. It is rather strange issue that you have. Maybe RPM database needs to be rebuilt, as we had for SDK. But it is an odd issue and I don’t know how well does rebuild would work

also zypper:
[root@XperiaXZ2c defaultuser]# zypper ref
error: rpmdb: fop_read_meta: /var/lib/rpm/Filetriggername: unexpected file type or format
error: cannot open Filetriggername index using bdb - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
Target initialization failed:
Rpm Exception
…so it’s starting to look more serious

Have you checked the storage (df -h)? Tried to rebuild RPM database?

Don’t have any RPM issues on my devices. So, cannot help much …

Storage looks ok, how do I rebuild rpm database? TIA

try rpm --rebuilddb. That was used with SDK

Hello. On step ssu ur it says unknown QconnmanTechnologyInterface scan reply “no carrier”.

Is it okay to proceed to next step anyway?

Great work, @rinigus. Thank you!

Edit: running it on my XZ2 (as reported on the github repo) and everything works swimmingly, aside from the minor regression in jolla-messages related to MMS. I haven’t tried it yet, but apparently downgrading jolla-messages and jolla-messages-settings to their previous versions solves it. Thread here. I’ll try it later and report back.

Edit: UPDATE: Following the procedure in the thread I linked results in a PERFECTLY functional MMS experience on this Tama port. There’s a regression in the jolla-messages app in 4.3.0.12 which makes MMS fail for varied reasons, with minimal indication (or no indication at all) in journalctl and ofono logger. I’ve been banging my head against this for a while, and this works 100%.

1 Like

Thanks a lot Rinigus, that did the trick.

1 Like

Is it possible to send mms in this build?