[Xperia 10 III] no audio input from microphone

HARDWARE: Xperia 10 III (XQ-BT52)
REGRESSION: no (first install on that hardware)


When making phone calls, other end doesn’t hear me.
With sailfish audio recorder, no sound is recorder.

If I use a headset, other end hears me and recorder records sounds.


No headset


Make a call or try to record with sailfish recorder


Other end hears me or sound recorded


No sound


None (new install)


Tested hardware with csd utility. Below microphone works.

Known issue: [] XA2 phone calls no audio

1 Like

No. It is not the same hardware and it is not related to phone calls but all audio input with builtin micropone.

So, no one can help me?
I’ve reflash Android 11 with Emma, tested microphone, it works.
I’ve reflashed SailfishOs: no microphone working.

So I’m back on Android 11 and I will wait for SFOS 4.5.
Hopefully, I haven’t bought the license yet.

I did not have the problem using 4.4 but after upgrading to 4.5 I do now the same problem as you have :frowning:

@elkiaer Audio recording never works? Did you try a recorder app?

I have solved it now.

Here is what I did:

  1. Open Terminal and run “pkcon refresh && pkcon update”
  2. Login as Root “devel-su”
  3. I have zipper installed so run” zypper ref && zypper dup” (zipper uninstalled the lates version of Chum)
  4. Run “zypper ref && zypper dup” again and Repositories was changed from Chum to others.
  5. Run “version –dup”
  6. Restarted the phone
    Now the Microphone is working again :blush:
    What of above points that did help I do not know, maybe the last point or all points :blush:

I’ve made a fresh install of SFOS 4.5: still no microphone working!

Just tried now on my X10 III with the audio record app and it worked as expected. I’m wondering what are the differences between my device and your.

Since I can record with sailfish-recorder when a headset in plugged in the jack, I have tried to record with the jack plugged and without the jack plugged and compared the entries in the journal log.
In the case the jack is not plugged in, the kernel sends an error at some moment. It seems that it is a very low level problem: hardware adaptation problem due to a different SoC? If it is the case, I fear there is no solution to my problem.

Yeah Known issue but nothing happends. After newest update still the same on Xperia 10 III. Had it on XA2 too and it is the audio not the microphone. Try to play music and it is silent. Booting helps for awhile till next boot etc. Has to be software issue.

When I flash SFOS, first line:
Found XQ-BT52, serial:HQ618W1C0C, baseband:62.1.A.0.675, bootloader:1322-1665_X_Boot_SM6350_LA2.0.1_S_108

No, As I stated above [Xperia 10 III] no audio input from microphone - #3 by phklrz
I have no problem with playing music.

Hmm Shazam works fine, just made a recording so my phone has that ok. Will test the mic next time it goes silent.

Went silent again and for sure everything is off even the microphone, got worse with he new uppdate. Earlier I had a working phone for days now it is everyday boot.

Obviously there is a hardware problem with my microphones.
With csd, when testing microphone, top microphone works but is recognised as below microphone while microphone recognised as top microphone doesn’t work.
I have found in pulseaudio config how to force top microphone as input for voice recorder but it does not work for voicecall since it uses port input_voicecall and I have not found how to force it to use top microphone.

I had a similar problem on my X10 III. Other couldn’t hear me, but I tested Sailfish Recorder and the microphone worked. I tested after with another contact and I couldn’t reproduce the issue.

EDIT: We found out that the internal loudspeaker of my interlocutor is defective.