Xperia 10 III — how can flashing succeed with a wrong unlock code?

I’ve been flashing my brand new Xperia 10 III and I screwed up.

I followed the official guide, but when I came to item 7.10, my finger slipped when I was hitting Enter and instead of

sudo fastboot oem unlock 0x0123456789ABCDEF

, 0123456789ABCDEF being the unlock code I received from Sony, the command which was executed was

sudo fastboot oem unlock 0x0123456789ABCDEF.

(note the dot at the end).

Understandably, instead of something like

OKAY [ 1.716s]
finished. total time: 1.720s

I saw

FAILED (remote: 'Incorrect format for unlock data')
fastboot: error: Command failed

Thinking that I’ll just try again, I disconnected the USB cable and connected it back while holding Volume Up. Surprisingly, green light lit up instead of blue. Reconnecting again yielded the same result.

So, I tried to power the phone on, thinking that maybe a power cycle will help. Except instead of a normal boot I was greeted with a familiar “your device is unlocked” warning, then the “Erasing” circle, and then the Android startup sequence. In other words, everything went exactly as if I didn’t screw up while entering the code.

Growing anxious, I powered the phone back off, connected it to USB while holding Volume Up (this time the blue light lit no problem), tried to run the fastboot oem unlock command properly, and got this in response:

FAILED (remote: 'Device already unlocked')
fastboot: error: Command failed

In desperation, I tried to run

sudo bash ./

and Sailfish installed just fine, as if nothing wrong happened – despite the fact that at no point was it unlocked with the code acquired from Sony.

This situation is freaking me out. Someone please explain me what the expected behavior of fastboot oem unlock should be when it gets a wrong key as it did in my case.