Xperia 10 III gets update to Android 13

… good news for such users.


What does this have to do with Sailfish?


I thought, that “the last possible version” of SFOS on Xperia 10 III could by now rely on Android 13 instead of Android 12. With good luck, I could you use my Xperia 10 III longer.

That is not how SFOS works, and actually SFOS needs “Android 11”* drivers to work.
That is what you downloaded from here.

*A longer and better explanation is needed here.

1 Like

Maybe I don’t fully understand SFOS by now, but in your link I read:
" Software binaries for AOSP Android 11.0 – Kernel 4.19 – Lena"

So I thought in future there would be something like:
" Software binaries for AOSP Android 13.0 – Kernel 5.x –…"

And a user of SFOS with newer binaries would profit somehow of that. If this nonsense, this thread should be erased ;-).

1 Like

might it not result in refreshed aosp packages in the open devices program, perhaps fixing some of the hardware driver related problems with camera, etc?



Does anyone know is it safe to flash Sailfish on Xperia 10 III if the device autoupdated itself to Android 13? If not, could someone give/link for instructions how to downgrade back to safe Android version? Is the factory reset good option?

It is “safe”, but it will maybe possibly most likely NOT work :upside_down_face:

Follow 1 2 and 3 here: Reverting Xperia device to Android OS and reinstalling Sailfish OS

Changed the wording from 100% sure it will not work to more weasel word like “info”…

Has anyone actually tried it yet, possibly also in combination with the latest Android 13 based Sony AOSP binaries for the 10 III?


Judging from another thread, you have. What are your experiences so far? Did you use Android 11 binaries as previously specified or did you use newer ones?


1 Like

Indeed, I have, some 10 months later :wink:. SFOS flashed on top of Android 13, with Android 11 AOSP binaries. I’ve been using it for a month now without absolutely any problems, whereas the benefits are that the echo issue is gone and display tint / color banding is also gone.

As for AOSP 13 binaries, I only tried them for a while and I couldn’t make mobile data work on them, so I reverted to AOSP 11 binaries. I intend to further investigate it, but since then I haven’t had time for it.


Did you go to Android 13 directly through Emma or upgrade through the phone itself? I just installed Android 11 but on there it was not possible to upgrade to Android 13 on the phone. Now I am trying to install Android 13 through Emma in stead.

I flashed Android 13 via EMMA. AFAIK, to get OTA updates on Android you would have to re-lock the bootloader first ( and then unlock it again in order to flash SFOS).


I didn’t have any luck. My try ended up in reflashing Android 11 and SFOS unto that. I had some problems with installing some Androis apps on SFOS and some other apps.

I can’t see any reason why it wouldn’t work for you. Not only I didn’t encounter any problems with freshly installing SFOS on top of Android 13, but even restoring a dd backup image of rootfs and home partitions containing an old, existing SFOS installation (originally installed over Android 11) also worked perfectly fine. Similarly, I didn’t experience any problems with installing any apps, neither Android nor native… So I’d encourage you to try once again some time.

I have relocked the bootloader and could only flash android 11 and no OTA updates anymore.

Maybe it depends on region / country, I have no idea. I simply flashed Android 13 via EMMA, and that’s it. I can see on the web that there is an even newer Android 13 release for the 10 III than the one available via EMMA, so I guess it is probably offered OTA. But I didn’t bother to relock the bootloader and check it, I stayed with the version from EMMA.

I take it back:

I flashed Android 11 and tried using it. Things seemed to work better than under 13 but for the first time I got the same “layer of soot” that you mentioned - I mean the color/tint on the display. Other things acted up as well. So I decided to flash Android 13 with EMMA again (I like the fact that the software has the same name as my wife :slight_smile: ).

Now, on Android 13, everything seems to work great. Everything has installed as it should, things are working well. The problem I had was hardware related - there is dust inside the camera cover/on the lens. Thinking about opening it up and fixing it since it apparently is not dust or water proof anyway.


I’m glad that you managed to make it work!


Do you have the loudspeaker bug: ?