Xperia 10 III flashing problems

I just recently bought the Sailfish for the 10 III and was trying to flash it to my device.
Following instructions here: How to install Sailfish X on Xperia™ 10 III on Linux - Jolla

But after flashing started I got the following error:
sudo bash ./  1 ✘  4s 
Flash utility v1.2
Detected Linux
Searching device to flash…
Found XQ-BT52, serial:XXX, baseband:62.1.A.0.587, bootloader:1322-1665_X_Boot_SM6350_LA2.0.1_S_108
Found matching device with serial XXX
Fastboot command: fastboot -s XXXX
>> fastboot -s XXX getvar secure
<< secure: no
>> fastboot -s XXX flash:raw boot_a hybris-boot.img
Sending ‘boot_a’ (25800 KB) FAILED (Status read failed (No such device))
fastboot: error: Command failed
Flashing failed (1)

Tried different ports + different cables, what could be the reason ?

Using Manjaro Linux

Use an USB2.0 port or hub. Sometimes putting your usb ports in USB 2.0 mode solves this problem.

1 Like

That’s strange, tried 3 different hubs, even cheap old hubs.
The USB devices manager recognizes them as USB2.0 HUB but the problem persists.
Sometimes it fails even before the ‘Sending boot_a’ with error:
<< getvar:secure FAILED (remote: ‘GetVar Variable Not found’)

Don’t understand the regularity but like you said probably it’s some synchronization issues.

Got this sorted out, used my raspberry pi 4 to flash the phone and it worked!