Xperia 10 III can't use Type-C headphones

REPRODUCIBILITY: always
OS VERSION: 4.5.0.24
HARDWARE: 10 III
UI LANGUAGE: Italian
REGRESSION: never worked on 10 III

DESCRIPTION:

I’ve a HUAWEI TYPE-C headphones. I tried to use them on my 10 III with SFOS.

PRECONDITIONS:

Having a type-c headphones

STEPS TO REPRODUCE:

  1. connect them to type-c usb port of your device
  2. it will not see them at all

EXPECTED RESULT:

the audio is routed to type-c headphones

ACTUAL RESULT:

the system doesn’t recognized nothing connected

MODIFICATIONS:

ADDITIONAL INFORMATION:

On my old 10 it worked! Just there was a glitch that when a new content is played it reset the volume and set to highest ( imagine me in the bed hearing one music, then skip to next one and jumping over because of overloudness ahhahaah)
Anyway on 10 III it really doesn’t see nothing of those headphones. maybe is in the kernel/drivers?

I believe you need to specify the exact type of headphones in use.

There are at least two different kinds of USB-C headsets. They can either use USB-C alternate mode (analog audio gets routed through certain pins of the USB-C socket) or purely digital, where a digital audio stream is transmitted over USB-C, and the headset/headphones needs to convert this to analog audio (and/or convert its microphone signal into a digital signal).
The Xperia 10 III doesn’t seem to support the alternate mode. I tried on a second device with Android, a Sony type 1310-9805 USB-C to 3.5mm adapter would not work. On the other side, four different USB-A audio devices (two Plantronics, a noname, a Logitech) would work on android with the aid of an USB-C<->USB-A-adapter, but not on sailfish OS (I would consider this a bug or missing functionality).
Unfortunately, I don’t have an Xperia 10 or 10 II at hand to compare.

So, if your headphones are “dumb” with pure analog input, I think the behavior is to be expected, otherwise it is a bug.

1 Like

AFAIK it is stated in the documentation that it is not supported. I think I read this around 4.X release.
I doubt that with 4.5 it changed. Bluetooth or 2.5" jack works fine.

See also this one. It says USB DAC works, just not for calls.

The issue you refer to mentions: HARDWARE: xperia 10ii, xperia xz2 compact

Yes, but i just tested it on the 10 iii, with the same result. So I’m pretty sure it’s a hardware independent bug in sfos

1 Like

Indeed you are right, it’s not the same hardware. I’m reacting to the previous message from @deloptes that says “it is stated in the documentation that it is not supported” which is what I find strange since it is known to work in other hardware.

Also here from @attah

I mean to support the idea that this should be a bug and not something known not to work. I can’t confirm myself, I’m interested in these issues and I’m anxiously waiting for a full confirmation of some model that works before purchasing one myself.

I have tried those headphones on the Xperia 10 Dual Sim and they worked! So what I am stating is that it’s a specific bug for the 10 III that doesn’t support it.
I’m talking about this Huawei 55030088 Headphones Type C, White, Wired: Buy Online at Best Price in UAE - Amazon.ae
the very standard ones from Huawei, that were shipped with the P40 for example.
10 III supports OTG of course, but I cannot try another pair of headphones since I don’t have others.

oh i just tried using a usb-c dac headset for audio playback on xperia 10 iii and they’re really not working. i only tested call audio earlier…

2 Likes

Yeah, something is screwy with the 10 III config. USB audio isn’t getting picked up in pulse for some reason.

3 Likes

So it is confirmed to not work for nobody on 10 III…
Damn

FWIW, I have successfully used my USB-C audio expansion card with my Xperia 10 (mark 1). However, when I unplug it, the phone reboots. That’s a separate bug, but a relevant data point, I’d say. That adapter contains its own DAC, so that’s not alternate-mode.

1 Like

When I had the 10 mark 1 it used to do the same as you mention here. Type-c headphones works, but volume is resetted every media you play and when you unplug them the phone reboots.
Exact same behaviour

I also have this issue on my Xperia 10 III. I tried plugging in my DAC usb headphones and nothing happened.

1 Like

I have the same problem with Xperia 10iii and usb c type headphones. Also with car aux connector (3.5 jack) and my Xperia 10iii usb c type or 3.5 jack. No connection, cant find device.

1 Like

So, it’s definitely not working on 10 III