Xperia 10 iii can't enable mobile data on talkmobile use the same settings used on my XA2 Plus

REPRODUCIBILITY: 100% now. Recurs after a restart.
OS VERSION: 4.4.0.68 (Android 11_4.19_v9a_lena)
HARDWARE: 10 iii
UI LANGUAGE: English
REGRESSION: Yes - Mobile data tested before and after device flashing. Seems to have happened in last few days - difficult to be precise as I WFH with wifi. Mobile data on the same sim still works fine on my old XA2 Plus running 4.4.0.64.

DESCRIPTION:

Using exactly the same System>Mobile network settings as in my XA2 Plus.
n.b. except the “4G calling (beta)” feature which i don’t think is foud on the old phone.

System>Sim sees the talkmobile card

but the top items is greyed out (shown below):
[unticked] talkmobile.co.uk
User SIM card “SIM1 | Talkmobile”

If i leave the phone on
[ticked] Select network automatically

Then the bit beneath is greyed out:
Network “Searching…”

If i click on “Select network automatically” to manually select, then i see:
"Talkmobile
GB15"

But if I attempt to click on it to select it then i get a top notification saying:
“Connection Error”

PRECONDITIONS:

STEPS TO REPRODUCE:

Insert Sim, turn on

EXPECTED RESULT:

Get a connection

ACTUAL RESULT:

Don’t get a connection

MODIFICATIONS:

None, clean install on a new device.
Mobile data tested as working before and after flashing earlier this week.

ADDITIONAL INFORMATION:

Photos attached showing working settings on my XA2 Plus

Part 2 of this problem:

Now have a new sim, that works fine in the old phone. But does not recognise mobile data in the new!

SW_binaries_for_Xperia_Android_11_4.19_v9a_lena.img



I have a similar problem. Maybe it’s the same.
Could you please try it with the APN protocol setting “Dual” and watch the journal log while turning on the mobile data.

You can enable live view of the journal log with the following command in terminal:
devel-su journalctl -f

Or after turning on mobile data with:
devel-su journalctl -u connman

Does the entry “DUAL no IPv4 address set” appear there?

1 Like

Update - tried the Sim card in Sim2 slot and i’m back to where I started originally in the first bug report:

I can make calls, but have no mobile data and the Mobile Settings report “Limited connectivity”.

Since I got this far, i tried your suggestion:

tried the above, got lots of scrolling text, but nothing among it looked like:
“DUAL no IPv4 address set”

Also did devel-su ifconfig and the rmet_data1 link encap stuff lists an addr for both inet6 and inet.

Thank you.

Have you tried my (dirty) workaround to get mobile data with SIM slot 2?

1 Like

thanks, will give it a go.

I experimented a bit more and found the following workaround for using mobile internet with SIM slot 2:
By switching the network mode to “2G only”, the connection is re-established and “Connected” is now displayed under “Mobile network”.
If you then switch back to the “4G preferred” network mode, the mobile data connection remains “Connected” and the mobile Internet connection works correctly with 4G.

I tried this, and after switching to “2G only” it does say [enabled] (tho no mobile data of course), but when i switch it to “4G Preferred” the phones switches back to [limited connectivity].

Also find that when i restart the phone with the sim card inside it updates the Mobile Network > MMS Access Point Settings from what is shown in the screenshot to:
Connection Name = talkmobile.co.uk (minus the “payg.” prefix)
Authentication = “None” (rather than “PAP or CHAP” + “wap/wap”
Proxy address = “212.183.137.012” (they added a zero in the fourth character group)

Settings which still don’t work.

from the community discussion on 18th august:

07:21:13 <flypig> #topic Is there a general cause to the various different mobile-data bugs with 10 III devices? (10m -- asked by PeegeeTips)
07:21:22 <flypig> #info <PeegeeTips> There are several bugs on the forum that look like they might be related.
07:21:29 <flypig> #info <PeegeeTips> 1. Xperia 10 iii can't enable mobile data on Talkmobile (UK):
07:21:34 <flypig> #link https://forum.sailfishos.org/t/xperia-10-iii-cant-enable-mobile-data-on-talkmobile-use-the-same-settings-used-on-my-xa2-plus/12485
07:21:38 <flypig> #info <PeegeeTips> 2. No IPv4 mobile data connection with MNO Telekom Deutschland possible:
07:21:44 <flypig> #link https://forum.sailfishos.org/t/ipv4-mobile-data-connection-not-possible/11917
07:21:48 <flypig> #info <PeegeeTips> 3. Mobile data (IPv6) connection used even though a WLAN connection (IPv4) is active:
07:21:53 <flypig> #link https://forum.sailfishos.org/t/use-of-mobile-data-ipv6-although-a-wlan-connection-ipv4-is-active/11918
07:22:02 <flypig> Here is our prepared answer:
07:22:08 <flypig> #info <Jolla> There have been a number of changes to the networking stack recently that could be related to the first two. Some users were experiencing mobile data connections when the data access point protocol was set to Dual:
07:22:14 <flypig> #link https://forum.sailfishos.org/t/4-2-0-19-xperia-10ii-no-internet-connection-on-mobile-data-when-leaving-wifi-if-data-access-point-protocol-is-set-to-dual-default/6697
07:22:19 <flypig> #info <Jolla> This was carrier specific, with a fix being rolled out in Sailfish OS 4.4.0.64:
07:22:30 <flypig> #link https://github.com/sailfishos/connman/pull/8
07:22:35 <flypig> #info <Jolla> For issue 3, a fix was introduced to work around the fact that VoLTE can create new IPv6 interfaces with potentially broken routing data (this is carrier dependent). This fix was rolled out in Sailfish OS 4.4.0.68:
07:22:44 <flypig> #link https://github.com/sailfishos/connman/pull/29
07:22:50 <flypig> #info <Jolla> Unfortunately it’s impossible to say whether the three are related without further investigation. We already had an internal issue lodged for issue 3 which has been looked into, and we also now have internal issues for the other two as well.
07:23:01 <flypig> #info <Jolla> The discussion in the forum is already quite comprehensive and very helpful, but as always any further detail you can add there is also appreciated.
07:23:22 <flypig> Is PeegeeTips here today? Any other comments welcome.
07:24:37 <ExTechOp> I believe this is kinda related to the long-standing issue of SFOS being quite bad at switching networks (mobile/wifi/mobile), specially for Android clients
07:26:56 <flypig> Yeah. Over the years we've squashed many bugs related to this (both for Android App Support and SFOS generally), but issues do arise.
07:28:37 <sledges> suggestion to use Ofono Logger when mobile data cannot be enabled at all (regardless of wlan state etc) and send logs (app has disclaimer that some information may be private, such as phone numbers, but emailing it straight to monich has been revoked due to in-app sharing broken)
07:30:41 <flypig> sledges, just to clarify, what should users do with the logs then?
07:31:32 <flypig> And would you add a comment on this to the minutes please sledges?
07:32:16 <flypig> 2 more mins on this topic.
07:33:25 <sledges> ensure there are no phone numbers in the logs (simply do not make/receive phonecalls during log grab); I believe sending them to jolla customer care is now the best bet, where data protection is ensured
07:33:42 <flypig> Great, thank you sledges.
07:34:24 <sledges> #info for mobile data issues please grab logs via Ofono Logger:
07:34:26 <sledges> #link https://openrepos.net/content/slava/ofono-logger
07:34:58 <flypig> Perfect, thank you.
07:34:58 <sledges> #info ensure no phonecalls made/received during the session, then provide the tarball to jolla customer care
07:35:24 <sledges> sadly logger is no longer in Jolla Store, i bet it's sandboxing/in-app sharing issues etc
07:36:11 <Thaodan> #info Ofono Logger is also available in chum.
07:36:15 <Thaodan> #link https://build.merproject.org/package/show/sailfishos:chum/openrepos-logger-ofono
07:37:15 <flypig> Okay, thanks for the helpful info. It's a shame PeegeeTips isn't here to comment, but hopefully this will be helpful to them.
1 Like

As an update - i tried again with my 10iii after upgrading SFOS to 4.4.0.72:
One first load (after upgrade, and restrart after inserting sim) i did very briefly catch a tiny error message scrolling across the top. Said something like: “problem enabling settings from sms” or some such. Doesn’t prompt on every sim swap, so can’t immediately recall precise message.

It also received the customary text message:
“we will shortly be sending you a text with some settings.”
Which never arrives…

Checking the settings for MMS after a new load of the sim seems to lose the settings that are present (and work!), in my XA2 Plus:
Connection name = “Talkmobile MMS”
Access point name = “talkmobile.co.uk(dropping the “pay.” prefix on working XA2 Plus)
Protocol = “Dual”
Authentication = “None” (dropping the “Pap or Chap” on working XA2 Plus)
Proxy address = “212.183.137.012” (adding a “0” into number on working XA2 Plus)
Proxy port = “8799”
MMS message centre address = “http://mms.talkmobile.co.uk/servlets/mms”

Outcome:
Regardless of replacing the settings exactly as found in my XA2 Plus, trying to register for 4G calling and restarting (as per the new .72 release), and trying all of this both sim 1 and sim 2, at no point do i get working mobile data.

Ofonologs:
Yes, i haven’t had the time to work Chum out yet, no doubt i will get there one day, hopefully usefully before SFOS 4.5 arrives but who knows…:

Hi @PeegeeTips. I spoke to a talkmobile representative, and they gave the following details for a Sony Xperia 10 III

Name – TalkMobile
APN - TalkMobile.co.uk
Proxy – not set
Port – not set
Username – wap
Password – wap
Server: not set
MMSC - not set
MMS Proxy - not set
MMS Port – not set
MCC 234
MNC 15
Authentication Type: PAP
APN type: default, supl.
APN protocol: IPv4
APN roaming protocol: IPv4
Enabled/disabled APN: APN enabled
Bearer: Unspecified
Mobile Virtual network operator type: GID
Mobile Virtual network operator value: C1​​​​​​​

Interpreting this for the Sailfish UI, I’d input these values as:

  • Data
    Name: TalkMobile
    APN: TalkMobile.co.uk
    Protocol (IP or IPv6 or Dual): IPv4
    Authentication: PAP
    Username: wap
    password: wap

I don’t think you need to get MMS working in order for data to work, but for the sake of completeness:

  • MMS
    APN: TalkMobile
    Protocol (IP or IPv6 or Dual): IPv4
    Authentication: PAP
    Username: wap
    password: wap
    Proxy address: none
    Proxy port: none
    MMS message centre address: none

Talkmobile also have a help video which shows different values for the MMS section. The person I contacted at talkmobile wasn’t able to confirm whether these are correct, but they might also be worth trying in case the above doesn’t work.

  • MMS
    APN: TalkMobile
    Protocol (IP or IPv6 or Dual): IPv4
    Authentication: PAP
    Username: Talkmobile
    password: <your password>
    Proxy address: 212.183.137.12
    Proxy port: 8799
    MMS message centre address: http://mms.talkmobile.co.uk/servlets/mms

Talkmobile is a MVNO on top of Vodafone UK, and according to the VoLTE provider wiki 4G calling isn’t fully working for Vodafone UK, so I’d suggest you disable that for the timebeing.

Probably you’ve already tried all of these values, but just in case you didn’t, would you mind please giving them a go and reporting back?

1 Like

Thank you very much for doing that, more than I managed to get out of TalkMobile support.

Those settings are differerent to what I (successfully) use on my XA2:

Data
Name: talkmobile.co.uk
APN: talktobile.co.uk
Protocol (IP or IPv6 or Dual): Dual
Authentication: PAP or Chap
Username: wap
password: wap

I tried the settings provided to you by TalkMobile:

Data
Name: TalkMobile
APN: TalkMobile.co.uk
Protocol (IP or IPv6 or Dual): IP (this is what you mean by "IPV4" right?)
Authentication: PAP
Username: wap
password: wap

And there was no change. No data connection, either right away after entering the settings, or after a restart.

Other information:-
Phone homescreen:
“3G” + ~30% signal strength showing on SIM icon.
Should i also have a little double triangle icon indicating data? I don’t.

On the main mobile settings page:
talkmobile.co.uk showing as enabled and “Connected”
Roaming showing “Always allow”
Network mode showing “Prefer 4G”
4G calling showing as disabled
Select network automatically show as enabled and Network as “TalkMobile”.

On MMS:

My XA2 settings that work ok on that phone (but makes no difference to mobile data - as expected?):

My 10IV settings that are in place when i add the sim anew (makes no difference to mobile data - as expected?):

My 10IV settings derived from what you list above (makes no difference to mobile data - as expected?):

Thanks for checking all of those settings @PeegeeTips.

Yes, apologies, I did mean “IP”.

Yes, you should see this as long as you disable Wifi. Similarly in Settings > Mobile network > Mobile data it should show “Connected” if Wifi is disabled.

So in summary, from what I understand, you have settings that do work on an XA2 and a 10IV, but which don’t work when you transfer them to a 10III. Similarly the Talkmobile provided settings don’t work on the 10III using the same SIM. This happened on a clean install, with a device that has previously had data working with the same SIM.

It may be worth you going back to Talkmobile to check that there isn’t something happening at their end. It’s hard to imagine what, but when I spoke to them they did say that you should contact them if the settings they provided didn’t work.

I’ll also try to find out if there’s anything else that could be causing this, or if there are any other logs that it would help to collect.

1 Like

Yes, this is all correct. Thank you.

Should i also have a little double triangle icon indicating data? I don’t.
[…]
[main mobile settings] showing as enabled and “Connected”

When my phone has these “symptoms” I see Unexpected data call status 4100 in logs, no exception.
Do you see that too in your logs?

1 Like

Thanks, i still need to sort out Chum so i can install ofonologs.
Will get there. :slight_smile:

Thanks, i still need to sort out Chum so i can install ofonologs.

If you don’t get around Chum and are familiar enough with the command line, get root on the phone then
#journalctl -u ofono

It should display the main ofono events, including the error message mentioned above.

1 Like

Ofono logs for both sets of tested data settings submitted to Jolla Customer Care.