Xperia 10 ii USB issue


I have bought a second Xperia 10 ii (XQ-AU51).

I have put it in developer mode and enabled OEM unlocking and USB debugging.

The phone service info shows “Bootloader unlock allowed: Yes”.

However, when I attach it to a computer in and boot it into fastboot mode (blue LED), the computer does not see the phone.

This is the same for both a Windows and a Linux (Mate) machine.

The Windows computer has the sony fastboot driver installed and I have previously flashed Xperias with Sailfish using this setup.

What is odd is, that if I plug my other, identical Xperia 10 ii into this same computer in fastboot mode, the computer recognises that phone and loads the driver.

The Linux computer does not see the phone either.

Has anyone come across this before?

Is there a way I can get the phone to talk to the computer so I can unlock and flash it with Sailfish?


have you actually unlocked the bootloader?

That’s something you do with fastboot. So by definition that cannot be a prerequisite.

oops, brain not working again!
Try different cables, usb hub?

Same cable worked with the other phone, but yes I have tried other cables

Fastboot is working as I checked it with a different phone.

In a terminal, enter

sudo dmesg -w

press Return a few times to get a visual divider - then try to connect the phone => show us.

I did this.

The first time the phone did not go to fastboot (green LED) when I plugged in the USB cable.

The output to the terminal was:

[ 139.653139] usb 2-1.2: new high-speed USB device number 3 using ehci-pci
[ 139.763019] usb 2-1.2: New USB device found, idVendor=0fce, idProduct=b00b, bcdDevice= 4.14
[ 139.763039] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 139.763046] usb 2-1.2: Product: Android
[ 139.763051] usb 2-1.2: Manufacturer: Sony
[ 168.184431] usb 2-1.2: USB disconnect, device number 3

I disconnected the cable and retried and this time the phone went to fastboot mode (blue LED).

The terminal showed no messages this time.

Clean the usb port of the phone, there might be packed up dust/dirt at the bottom of the port. Maybe the cable doesn’t get deep enough to get a good enough connction.

The output looks unproblematic, but thin. Still, Linux clearly sees the phone.

So that works then?

Intermittent failure?

Linux sees the phone, just not in fastboot mode.

I repeated the steps several times with the same result.

You are trying to flash.Maybe you are running into one of these problems.


If this read Google you’re likely in fastboot mode.

I’m trying to unlock the bootloader in fastboot mode.


I just came back from a painful process of flashing SFOS.

To cut a very long story short, there can be problems with USB ports, esp. on laptops (if you have a non-portable computer, be wiser than me and try that first).

Things I tried (in order - the last one helped):

1 Like