Xmpp contacts offline in addressbook/messages

HARDWARE: Sony Xperia XA2


Since the latest update, though i can set my xmpp account to online or away from the ‘settings → presence’ menu, i can receive and send xmpp messages, but the status of the contact (online, busy, away) is not anymore seen neither in contacts app, nor in messages app.

i can never know if the contact is online before sending the message.



  1. setup an xmpp account, make it active
  2. go to settings → presence. set yourself online
  3. open ‘contacts’ or ‘messages’ app - there is a short vertical line near each contact. it should be grey, if the contact is offline, green, if the contact is online, orange, if the contact is away.

it is always gray, though the contacts are online, and we are able to chat with them.


it is expected to see the xmpp status of the contact in the contacts and messages app.


the status of the contact (online, busy, away) is not anymore seen neither in contacts app, nor in messages app.


i had to install telepathy-gabble-plus, but i always install this after update, otherwise xmpp doesn’t work at all. don’t know when jolla will fix that.


1 Like

Thank you for your bug report! Could you please edit your post and add all steps to reproduce your bug?

Um, which settings? I don’t have presence in the global settings. do you mean in messages?

Looks it has a missing preconditions/step. Perhaps package telepathy-gabble must be installed. I read there is another package from OpenRepos called telepath-gabble-plus, but I don’t know which package @norayr has installed. In any case, it would help us to go further.

I personally don’t use XMPP. If someone else can test it, I’ll be grateful.

i mentioned in the ‘modifications’ section that i have telepathy-gabble-plus installed. otherwise xmpp doesn’t work at all.

this is presence in settings menu:

this is when you enter it:

Ah, ok. I have that in neither 4.4 on the Volla/GS290 port NOR on a (not paid) Sailfish X install (today) on an Experia 10 ii. Hmmmm.

I’m been fairly happy with testing of Shmooze, but don’t understand why the telepathy stack isn’t kept up to date.

Installing the gabble-plus package and the sharing plugin did nothing on either device/port.

try to use nephros’ script from the other thread and it may bring you the settings menu section.

you just need to configure the xmpp account first.