XA2 Plus H4493 trouble resetting to stock

A call for help from the SailfishOS community :slight_smile:

So I had SailfishOS working fine for 6 months or so, then got tempted to try LineageOS and installed it. But I could never get wifi or cellular working though, so I am trying to re-install SailfishOS. I have managed to install, but the phone is unresponsive except for the drop down menu.

I realise I need to revert to an older android (as lineageOS is 10), but the Emma tool is not letting me.

All documentation on Jolla’s site says my model is supported, but Sony’s site says my model is not one of their supported ‘open devices’. What can I do to reinstall a stock rom? seems Emma/Sony Flash Tool is not gonna work. Any pointers?

1 Like

When you try to connect to Emma tool, is the green led on?

Download Xperia new Flasher and xperifirm and follow the instructions

Thanks for the suggestions.

Emma works and recognises the phone but it says it is not supported and there are no firmwares or updates available.

I used Flasher and Xperifirm and it worked! For some reason calls and Bluetooth only worked after I flashed the Hong Kong rom, after first trying another one. Anyways thanks for the tips!