Xa2 plus dual sim bootloop

i have an xperia xa2 plus dual sim which i put on my bike with a rubber band and when it was raining once the device turned off and it is in a bootloop since then. i tried flashing it with sfos 4.5, which was successful, also with sfos for the single sim variant, but it only shows the unlocked screen, the sony logo and then shuts itself down. if i put it in flashmode it only stays for about 10 seconds in flashmode and then turns off. fastboot mode is working fine
here is the output from sudo fastboot getvar all:
(bootloader) unlocked:yes
(bootloader) off-mode-charge:0
(bootloader) charger-screen-enabled:0
(bootloader) battery-soc-ok:yes
(bootloader) battery-voltage:4073
(bootloader) version-baseband:1315-1734_50.1.A.13.123
(bootloader) version-bootloader:1310-0301_X_Boot_SDM630_LA1.0_O_123
(bootloader) variant:SDM EMMC
(bootloader) partition-type:userdata:ext4
(bootloader) partition-size:userdata: 0x500000000
(bootloader) partition-type:system_a:ext4
(bootloader) partition-size:system_a: 0xB5000000
(bootloader) has-slot:modem:yes
(bootloader) has-slot:system:yes
(bootloader) current-slot:_a
(bootloader) has-slot:boot:yes
(bootloader) slot-retry-count:b:7
(bootloader) slot-unbootable:b:no
(bootloader) slot-successful:b:no
(bootloader) slot-retry-count:a:4
(bootloader) slot-unbootable:a:no
(bootloader) slot-successful:a:no
(bootloader) slot-count:2
(bootloader) secure:no
(bootloader) product:H4413
if anyone has an idea for me i would be glad

I don’t think you will have success trying or asking for a software solution to a wet phone.
Letting it dry out might work…

I forgot to mention that this happened 2 years ago

1 Like

Then spontaneous recovery can be ruled out… You’ll need to Louis Rossmann it.

1 Like

Lol. You mea i should send it to him to repair it?

Well, more as a description of what it most likely takes.
Cleaning out corrosion, possibly reflowing a few things… you know the deal.

I see. Que tip^^ but it probably means replacing a chip or a Microcontroller

Do you have a way to use EMMA, maybe a repair is possible there?

Yes i could do that. I tried earlier but failed installing the drivers successfully. I could dig into the driver thing a bit more

For the drivers you need a current Windows otherwise they will be denied. If it doesn’t work, contact me and I’ll write down how you have to proceed.

i’m having difficulties with the driver indeed. do you mean windows 11 or an up to date windows 10? i have 4 day old security updates on windows 10 and feature updates are one or two years old

I mean a highly updated Windows 10 version 22H2.