XA2 Dual Sim [4.0.1.45] Outside-of-Screen Gestures become partially unresponsive when the phone is charging from USB

REPRODUCIBILITY (% or how often): 100 %
BUILD ID = OS VERSION (Settings > About product): 4.0.1.45
HARDWARE (Jolla1, Tablet, XA2,…): XA2 Dual Sim
UI LANGUAGE: Finnish
REGRESSION: (compared to previous public release: Yes, No, ?): Yes, came with the upgrade

DESCRIPTION:

The Sailfish “gesture-reader” code seems to become partially unresponsive when the phone is on charger and charging. The swipes from outside the screen won’t register as Sailfish Gestures all the time but seem to be interpreted interpreted as “in-app” gestures.

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Put the phone on charger (=plug in the USB)
  2. Do outside-of-screen gestures (from the sides, from the top, from the bottom)
  3. See the phone ignore the gesture a lot of time / do some in-app action.
  4. Take the phone off the charger (=unplug the USB)
  5. See everything work properly as expected
  6. Put the phone back on charger (=plug in the USB) to reproduce the issue

EXPECTED RESULT:

Swipe from side: close the app

Swipe from middle top: open the top menu

ACTUAL RESULT:

Swipe from side: the app will close only about 1-2 times out of 5, otherwise the swipe gets ignored or does an in-app action

Swipe from middle top:the Top Menu will open only about 1-2 times out of 5, otherwise the swipe gets ignored or does an in-app action

ADDITIONAL:

I have USB Tethering installed and had it installed while upgrading to 4.0.1.45.

Does this happen when connected to any USB port/device/charger?
I had this on Jolla1 but it turned out, it was a faulty charger.

1 Like

@michfu Dang it, I think you are onto something: charging from a computer USB port, the Gestures work just fine.

The charger I was using is an old iPhone 3Gs one, with USB-c cord from another manufacturer.

BUT, I tried charging with a Samsung fast charger, and I again got the issue I described with this Samsung charger too.

I’m at work so I don’t have the original Sony charger with me and can’t try it for now.

And, the issue did come only with the 4.0.1.45 upgrade. With 3.4.0.24 and the releases before that, everything worked as expected.

Thanks, @michfu. You got it right.

I tested with the original Sony charger that came with the phone, and there’s no buggy behavior with it. The Gestures work as intended with the proper XA2 charger.

Not a bug then, but a feature that someone else with non-stock charger may also get upon upgrading to 4.

2 Likes