WLAN/Capture portal not working properly until sandbox request is accepted

REPRODUCIBILITY: n/a
OS VERSION: 4.4.0.64
HARDWARE: XPeria 10 II - dual SIM
UI LANGUAGE: en
REGRESSION: yes

DESCRIPTION:

When trying to access wlan that requires sign-in, the notification flashes briefly before disappearing. Most probably because the Capture portal application doesn’t have proper sandbox permissions from scratch.

PRECONDITIONS:

Open WLAN that requires sign-in.
Newly flashed phone.

STEPS TO REPRODUCE:

  1. Try to connect to open WLAN that requires sign-in

EXPECTED RESULT:

Notification that the WLAN requires sign-in remains open long enough for a user to tap it, to access the login page.

ACTUAL RESULT:

The notification that the WLAN requires sign-in flashes briefly and then disappeares.

MODIFICATIONS:

Patchmanager with “Right side broken swipe patch” installed.

ADDITIONAL INFORMATION:

If the user predicts the notification, and is quick enough, it’s possible to tap it when it briefly flashes and then the sandbox permission request can be seen and accepted. After that everything works as expected.

The WLAN I had issues with was open WLAN provided by SJ (big train operator in Sweden) on their trains. I have successfully connected to this WLAN previously using Sailfish on Xperia X, XA2 and 10, but not sure I have done it after introduction of Sailjail.

I know it can be some sensitive data, but is it possible to provide which Wi-Fi portal doesn’t work properly?

I know for instance that free Wi-Fi provided by the Swiss Federal Railways (SBB CFF FFS) doesn’t work correctly. You need to open a http website to have access to the Internet.

Sure, I’ll add it the original post as well. The issue I had was with SJ’s (big train operator in Sweden) open WLAN on the train I was on. This was the first time I connected to an open WLAN with my recently flashed Xperia 10 II. I have successfully connected to this network on my previous device (Xperia 10 running all versions from supported release to 4.3, but cannot recall last time I tried with that device so not shure I did it after sailjail was introduced). Since the WLAN worked with Sailfish previously, I don’t think it’s something to do witj the WLAN implementation.

Hotspots in the german private “Metronom” trains do not work properly - the redirect to the splash site raises an https-security issue and the splash page won’t open.
Only workaround for me is to call the gateway IP (10.101.8.84) by hand in the sailfish browser.

Ok, but this worked properly as soon as I was able to accept the sandbox permission request by Capture portal. Then I was redirected to proper “Accept our terms” page and after I’ve done that I was able to use the WLAN.

Are you redirected if you open http://neverssl.com ?

Haven’t tried that (and didn’t know that site either). Will try once I’m on such a train again ( which might take a while since I’m totally fed up with public transport in Germany but rather rely on my car:-))

Mmh, I don’t remember anymore but I think I had to open http://neverssl.com
With some luck, SJ use similar infrastructure as SBB CFF FFS.

Switzerland? Lucky you, great public transport.
I even used to go on daily skiing trips by train when I was living in Zurich;)
Germany has the faster and less stressfull highways though:)

The problem isn’t that I can’t access the login screen, it worked as soon as I accepted the sandbox permissions, instead my problem is that the notification disappears within half a second, due to mentioned missing permissions.

Thanks for the report @Mohjive, and for the following discussion. I’ve created an internal bug report and tagged this as “tracked”. If there’s progress to report on fixing it we’ll do our best to post it here.

1 Like