Wireshark install from OpenRepos: missing libgcrypt.so.11

Dear community. I am pretty new to SailfishOS and gemini PDA, I am trying to install wireshark, and it fails with the error:

Nothing provides ‘libcrypt.so.11’ needed by the to be installed wireshark-1.0-1armv7hl

Please help.

Thank you in advance

Where are you trying to install it from?

Maybe here wireshark | OpenRepos.net — Community Repository System ? Same comment there. I think, given that it’s from 2014 it may need a bit of work.

Out of curiosity I tried now to search for ‘libcrypt.so.11’ on Storeman, and it led me to Wireshark app. On trying to install it activated the source NielDK, but did not offer to install in pull down menu. ‘libcrypt.so.11’ also not available in Storeman, Chum or by ‘devel-su pkcon install libcrypt.so.11’. How can one get this lib?

edit: is this usable for Sailfish phones?
(mind the g!)

The missing dependency is libgcrypt.so.11.

The version in is 20. Symlinking doesn’t work.

1 Like

This version is present on my Volla.
Does this mean that simply Wireshark version is outdated and needs update by the dev to work with the modern libs?

I recommend you immediately disable and remove the NielDK repo.

It’s one of the dangerous ones as it has packages which overwrite system ones and has not been maintained for a loooong time!


Many thanks for the warning :sparkling_heart: ! Done.

Why is it even still available? Well, I understand “because he didn’t take it down”, but I really think someone should, though I don’t know who.

Thank you all.
Yes, I mistyped.


As I understand, Wireshark needs that exact lib during the installation.
And that lib is pretty old.
Anyway, what is the way to install the Wireshark on the Sailfish OS?
Or, maybe someone could recommend another app with similar functionality.
Please help.
Thank you again.

1 Like

I think I might have installed a wireshark flatpack pakage a long time ago (but I might be wrong?).

1 Like

Thank you.
I am a newbie.
Please give me a reference how to install something with a flatpack, or another way to install wireshark on the sailfishos.

thank you in advance

Even if it did work - actually, I got it to start on my XA2 but there’s an error message of something being disabled because of running as superuser - it’s 32-bit. Volla, PinePhone, Xperia 10 II and newer are 64-bit.

My Zyxel NSA325 has libgcrypt.so.11.6.0 from 2017. It’s about 750 kB.

Edit: the warning message points to

I think the project is on hold for a while but it used to work fine on my gemini in 2021: Flatpak support for Sailfish OS · GitHub

I haven’t tried it recently though.

Does it have to be wireshark?

Because tcpdump is available natively. You can use it to capture dumps and load them into wireshark on another computer.


You may also find a compatible (armv7hl) rpm from some other distro (e.g. fedora).

I did some further digging: version 11 is GCRYPT_1.2, version 20 is GCRYPT_1.6.

I sent a copy of my version 11 to all the people who asked for it - a grand total of 0. The hard way to get it is to reset a Jolla 1.

GCRYPT_1.2 is referenced in the following files in the Wireshark rpm for a total of 14 hits (2 per file, 8 from the symlinks) as reported by Midnight Commander’s Find file:
/usr/lib/libwsutil.so.0.0.0 (+ 2 symlinks)
/usr/lib/libwireshark.so.0.0.0 (+ 2 symlinks)

Could you please give me a link?
Thank you.

I will try.
Thank you.

Thank you.
I have experience with a Wireshark, and no experience with the tcpdump. I think it is a time to study something new.
Thank you again.