WIFI Login via Captive Portal fails (Deutsche Bahn)

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): OS
HARDWARE (XA2, X10, X10 II, …): X10 II
REGRESSION: (compared to previous public release: Yes, No, ?): ?


Trying to join the public train WIFI (WIFIonICE) in Deutsche Bahn (german railways). The captive portal pops up in the Sailfish Browser. But when I click on the “Connect” button, nothing happens.

I am pretty sure this is a Javascript browser incompatibility… Hoping for a Browser update soon that will also fix these issues. For the time being, no free internet in german trains :confused:

Also, I cannot “choose” to use the Android Firefox I installed, which would very likely fix this issue.



  1. Travel with ICE / Deutsche Bahn
  2. Try to connect to their WIFI


The Captive Portal Javascript works with the native Sailfish Browser OR when it is possible to choose a browser for opening the captive portal page.



(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Sorry, no screenshots. Will try to make one next time.

Can you test if this is working in the browser? So call any http page (not https and no redirect to https!) like http://motherfuckingwebsite.com/ in the browser and you should be redirected to the portal page.

I’ve seen a similar behavior in the wifi of the german supermarket Kaufland andit is working in the browser, so the portal application poping up automatically seems to have a webview with a different configuration or feature set than the browser.

Using the same trick you can also try an Android browser.

Captive portal mode only works on sites where there is nothing to enter, like where the user only has to click an ‘accept’button or sth… The DB-site requires the user to set a hook before clicking’accept’, that’s why it doesn’t work. Works fine in the browser, though.


Yes, pure HTTP is working in the browser. That page displays correctly and shows a little warning symbol near the address.

What you describe makes sense. Probably a different configured webview.

After all, the DB WIFI page displays correctly in the portal applilcation, just that “clicking” the “agree” button shows no reaction. IIRC the same happened in Austrian trains.

I don’t remember if I had to check a checkbox before clicking the button…Will try next time :slight_smile:

Unluckily, captive portal pages are build that way and it’s a pity that it doesn’t work with Sailfish.

Are you saying that I can open the captive portal page in the normal browser and that would allow me to connect to the WIFI? It’s a couple of month ago, so I don’t really remember everything, but IIRC I tried several things to make it work, but none worked.

The captive portal page at the Hamburg Hochbahn stations is provided by a local provider (https://mobyklick.de/) and doesn’t provide a checkbox, thus works fine with Jolla’s captive portal client.
For DB WiFi, just open either wifi.bahn.de or login.wifionice.de in the browser and start from there.

I can confirm using the browser directly makes the use of open WiFi at my doctors patient net possible.

This has been fixed with SFOS 4.4.0, at least for Wifi at Deutsche Bahn.


Thanks @jollajo for checking that it’s fixed. I’ve tagged it as “fixed”, but if anyone still experiences the issue, please say.