Why alarm clock is still loud in silent mode+do not disturb mode?

Why alarm clock is still loud in silent mode+distraction free mode? I would expect that everything including alarm will be silenced when these two mods are enabled. Please make some option in settings/clock app to choose if user want or don’t want loud alarm when these mods are enabled.


I’m not familiar with ‘distraction free mode’ (= do not disturb in settings?) details. But regarding ‘silent mode’ one could say: because it was explicitly required to be like this in N900/Maemo, the behaviour was retained in N9/MeeGo, and then got inherited by Sailfish.

An example of competing expectation is: put phone in silent mode in evening and still get woken up by clock alarm in the morning.

Then one needs to consider the annoyance levels of e.g. getting an alarm during a concert/similar vs. oversleeping/missing train/whatnot due to alarm not ringing.

While settings ui does not support this, it should still be possible to tweak ‘silent’ behaviour from command line:

# NB This needs to be run as user, not as root.

# Also, to avoid possible cross talk hiccups, it probably would
# be good idea *not* to have settings app running or silent
# mode active while doing things like these...

# select a different sound file
profileclient -s silent:clock.alert.tone=/usr/share/sounds/jolla-ringtones/stereo/poppy-red-tone-2.ogg

# turn off vibration
profileclient -s silent:vibrating.alert.enabled=Off

# or make clock alarms completely silent
profileclient -s silent:clock.alert.enabled=Off

As profileclient is not installed by default, you’d probably need to do this first:

# Installing packages requires root privileges
pkcon refresh
pkcon install profileclient

And expect any/all of the above to get reset when changes are made via: Settings → Sounds and feedback.


There also is an app for that. “Alerts” from OpenRepos adds an settings page in system settings where you can set alarm volume. But of course this also does not connect to silent mode.

1 Like

I’m using ambiences for silencing my phone. I assume don’t disturb mode mutes email, sms & chat notifications.