Whisperfish - The unofficial SailfishOS Signal client

Please also check that your /usr/share/sailfish-browser/data/ua-update.json.in from package sailfish-browser contains the google user agent overrides, reCAPTCHA won’t work without those.


Hi @rubdos Thanks very much for the suggestions. Yes I did wait and do a reboot.

Will try other things you suggest but have just done

This gives:
Installed all-translations-pack-0.7.6-1.11.19.jolla.noarch (installed) Collection of all system translations
Installed sailfish-components-webview-qt5-1.2.14-1.15.6.jolla.armv7hl (installed) Allows embedding Sailfish OS Browser WebView into applications
Available sailfish-components-webview-qt5-1.2.14+jb53103.20210304094636.f48fd13-1.armv7hl (openrepos-rubdos) Allows embedding Sailfish OS Browser WebView into applications
Available sailfish-components-webview-qt5-devel-1.2.14-1.15.6.jolla.armv7hl (jolla) Sailfish OS WebEngine development files
Installed sailfish-components-webview-qt5-pickers-1.2.14-1.15.6.jolla.armv7hl (installed) Picker and selector QML components used by sailfish-components-webview
Available sailfish-components-webview-qt5-pickers-1.2.14+jb53103.20210304094636.f48fd13-1.armv7hl (openrepos-rubdos) Picker and selector QML components used by sailfish-components-webview
Installed sailfish-components-webview-qt5-popups-1.2.14-1.15.6.jolla.armv7hl (installed) Popup and alert QML components used by sailfish-components-webview
Available sailfish-components-webview-qt5-popups-1.2.14+jb53103.20210304094636.f48fd13-1.armv7hl (openrepos-rubdos) Popup and alert QML components used by sailfish-components-webview

I’m guessing that the refernece to “Available” is relevant? Does this help?

Zypper dup worked fine for me. Now I can get past the captcha.

Yet now I am seeing no contacts.

Aren’t those overrides shipped with any installation, or do I need to provide some instructions? Thanks for your work @kende :slight_smile:

@ninepine You seem to still have the original webview installed, for some reason my patch didn’t come through. You can try zypper dup as root, if you have zypper installed. Otherwise, we’ll think of a pkcon command that works for you. Probably pkcon upgrade or something, but I’m not sure.


Yet now I am seeing no contacts.

I just noticed that too on alpha.8. It is fixed on master branch though, so you should see a Whisperfish update in the next two weeks that fixes a lot of stuff :slight_smile: (you can already see the changelog, still growing, on OR). If you really want your contacts, you can pick a -dev version from the CI, but keep in mind to manually downgrade to OpenRepos (or keep manually updating by picking from CI).


Thanks a lot - looking forward!

1 Like

@rubdos Thanks for the suggestion to use zypper. Am a novice at this so a bit reluctant to hit “y” after running zypper.

zypper dup identifies a lot of potential changes

22 packages to upgrade, 258 to downgrade, 11 new, 66 to reinstall, 17 to remove,
19 to change vendor.
Overall download size: 231.8 MiB. Already cached: 0 B. After the operation, 9.5
MiB will be freed.
Continue? [y/n/v/…? shows all options] (y):

Would like to just amend the minimum so is there a version of the zypper command that is more precise please?

The overrides should be there, latest google overrides are in sailfish-browser 2.0.2 or newer version.

@ninepine “zypper up sailfish-components-webview-qt5” or “pkcon update sailfish-components-webview-qt5” should install the patched webview for you.

1 Like

@kende neither would work, since we’re switching vendor here. pkcon doesn’t even know upgrade :slight_smile:

@ninepine try zypper ref ; zypper dup -r openrepos-rubdos, that should limit dup’s to my repo.

If it still refuses to get @rubdos’s versions, this should force it through:

devel-su zypper install --oldpackage --force sailfish-components-webview-qt5-1.2.14+jb53103.20210304094636.f48fd13-1 sailfish-components-webview-qt5-pickers-1.2.14+jb53103.20210304094636.f48fd13-1 sailfish-components-webview-qt5-popups-1.2.14+jb53103.20210304094636.f48fd13-1

@flypig and @rubdos thanks both. I think I’ve managed to change versions. I did get a response:

There is an update candidate for ‘sailfish-components-webview-qt5’ from vendor ‘’, while the current vendor is ‘meego’. Use ‘zypper install sailfish-components-webview-qt5-1.2.14+jb53103.20210304094636.f48fd13-1.armv7hl’ to install this candidate.

So I tried ‘zypper install sailfish-components-webview-qt5-1.2.14+jb53103.20210304094636.f48fd13-1.armv7hl’ and selected what appeared to be the correct option (1). Will see if I can register now.

Thanks again.


Yes that does it thanks. Never been so pleased to see a parking meter! CAPTCHA works, Whisperfish registered. Thank you @flypig and @rubdos


Looks like Whisperfish is back in business for the next few weeks then :innocent:


I’m glad it’s working. Kudos to @kende for fixing webview.


Does that mean that anybody else can see the contacts’ name ?
Since the upgrade to last SFOS, I don’t see the name of the contacts I chat with in whisperfish, I can only see there phone number, and I thought it was “normal” with current app version. It is not?
By the way, I don’t see my contacts on android app Whatsapp since last SFOS update, could it be related?

If I get this right, the fix of the contact name issue is in the current developer version, which will be released to openrepos in the coming weeks

I thought I included the fix in alpha.8, but apparently I did not. The fix is included in the development versions indeed. Ya’ll need some patience now, and it will be rewarded. Feature parity with official Signal is closing very rapidly now :slight_smile:


Yeap I am patiently/eagerly looking forward to uninstall the android app :slight_smile: Thanks for all the hard work and the professional approach with build pipelines CI/CD bug tracking and all :slight_smile:


Just a simple, works for me with 3.4 on a Volla. Thanks a bunch!


I’ve put an 0.6.0-alpha.9 on OpenRepos with a hotfix for new SailfishOS 4.0 installs. This was reported on OpenRepos, and could imply that Whisperfish does not start. If you don’t have any issues with Whisperfish not starting, there’s no real reason to upgrade.

Meanwhile, we’re still working hard on getting the database migrated and tested. If you’re currently running Whisperfish and want to help, I’d love some extra feedback on this test. It’s very easy: download the test, run it on your phone, and let me know if something seems off.


I’ll try that out later this evening.