Whisperfish - The unofficial SailfishOS Signal client

Expect a DM :slight_smile:

A Wiki is maybe a bit too crazy; are there others who did that in the past? I imagine the community could also positively contribute to it, however.

Great!

I’m not sure if anyone used a wiki for this purpose (we have many wikis used for a variety of things), but I don’t see why not. People are generally very considerate of the wikis I think, so you could add a sign asking only Whisperfish devs to edit it, and I’m sure others would respect that.

I believe the most used wikified opening post is Apps that haven’t been ported to aarch64, and that seems to have worked very well! It was meant to be a collaborative post in the first place, which makes the “use case” a bit different, though. I think it’s worth a try anyway.

4 Likes

Sounds good, let’s try that!

2 Likes

It’s now a wiki. Good luck :smiley:

3 Likes

I’m falling behind but I check and cross reference as much as I can… great work guys!

Unfortunately registration still fails for me. Whisperfish crashes with an exception:

thread 'main' panicked at 'ls command failed to start: Os { code: 2, kind: NotFound, message: "No such file or directory" }', src/model/prompt.rs:155:14

looking at the code the message is misleading as it’s not ls that’s missing, but /usr/bin/sailfish-qml, and that later executable doesn’t exist on my Xperia 10 II with Sailfish 4.4.0.64. What workaround do I need to make this work?

I can file a bug report as well, if you want, but that will probably have to wait a day or two.

@direc85 did we forget to package that file? :blush:

Or did I remove it when I was refactoring something in the RPM? :thinking:

Works for me on xa2 SFOS 4.4.0.64 (32 bit)

sailfish-qml is provided by Sailfish. I’ll have a look at it, probably in sailjail or packaging… The ls is a typo in the error message, whoops :slight_smile:

2 Likes

Trying to figure out if I did something wrong, I see that both the “normal” and the 3.4 clients shows as installed in Storeman.

I know that I explicitly installed the main client the other day and today all I did was update it. i wonder what makes Storeman cunfused.

I will try to remove it and re-install it to see if it helps.

That does not help. They will both show as installed, that’s normal. There’s definitely something wrong at our side!

2 Likes

Ok, I wont do that then :slight_smile:

Wouldn’t it be possible to suffix the 3.4 client rpm/name with -3.4, or similar, to avoid confusion?

I honestly don’t think I’ve thought about that yet… I’ll give it a shot!

1 Like

That is really weird. Can you run this command on your device?

pkcon search file "/usr/bin/sailfish-qml"

It should list libsailfishapp-launcher as installed, is this the case? If it’s not, you can install it manually by running this command:

devel-su pkcon install libsailfishapp-launcher

If that helps, I think I know where the issue is.

1 Like

That worked! :slight_smile:

[root@Xperia10II-DualSIM defaultuser]# pkcon search file "/usr/bin/sailfish-qml"
Searching by file
Starting
Refreshing software list
Querying
Finished
Available       libsailfishapp-launcher-1.2.13-1.7.2.jolla.aarch64 (jolla)      QML application launcher for Sailfish apps
[root@Xperia10II-DualSIM defaultuser]# pkcon install libsailfishapp-launcher
Resolving
Querying
Testing changes
Finished  [                                   ] (0%)
The following packages have to be installed:
    libsailfishapp-launcher-1.2.13-1.7.2.jolla.aarch64 QML application launcher for Sailfish apps
Proceed with changes? [N/y] y
Installing
Starting
Refreshing software list
Installing packages
Downloading packages
Installing packages
Finished
[root@Xperia10II-DualSIM defaultuser]#

Now I have successfully registered with Signal! Thank you for your work. :heart:

3 Likes

@direc85, are you patching that up, or shall I do the honours? :’-)

Reported and fixed!

(Too many communication channels to see them all at once :slightly_smiling_face:)

2 Likes

I got error: “Failed to setup signal client” after verification code. How can i check error? X10III.

Do you mean after entering the verification code, or after requesting it?

Run harbour-whisperfish --verbose from the command line, it’ll dump you the necessary logs.