Whisperfish - The unofficial SailfishOS Signal client

Don’t expect or hope for an organization (of any sort) to solve your issues. You should control your privacy. Anyone can abuse or not respect laws etc.

It’s true Signal is centralised, and there are real dangers associated with that, but as far as I’m aware there’s no native Matrix client that comes close to Whisperfish for functionality or privacy on SFOS.

This figure from Zak Doffman’s Forbes article has been doing the rounds and gives a nice summary (I’d have been interested to see Telegram or Matrix on there as well).

6 Likes

While I prefer Matrix too, Matrix is not something that you can tell grandma to “just install”. The UX is on a completely different level. Signal is just fire-and-forget, and at least they don’t have a Silicon Valley start-up with a bunch of capital-hungry investors behind them. They have a small group of privacy-minded people running the thing. IMO, the people behind the technology are at least as important as the technology itself, if not a lot more important.

FWIW, @Fuzzillogic, we use Matrix to organise the people that write Whisperfish, feel free to come say hi :slight_smile:

4 Likes

Decentralization comes with its own disadvantages concerning privacy. They spread tons of meta data to federated servers you will never have control of, as explained e.g. here:
https://gitlab.com/libremonde-org/papers/research/privacy-matrix.org/-/blob/master/part1/README.md

2 Likes

Indeed, it’s not as easy as “let’s decentralise” or “let’s peer-to-peer”. In fact, my PhD is about (privacy on) peer-to-peer networks! But hey, let’s keep things to topic from here on. Feel free to come and have a chat on Matrix or Freenode, we often take those tangents there :slight_smile:

7 Likes

Since I removed old config, the current alpha 6 works quite well.

1 Like

Sounds like you still experienced a bug wrt. the config files, would you mind commenting on that? Also, “quite well” doesn’t imply “perfectly”, are there by any chance bugs that you could report that are not yet in the issue tracker? Thanks for you feedback, much appreciated!

By the way, guys, since the Tweetening of mr. Elon Musk and the WhatsApp rule change-about, the userbase of Whisperfish seems to have doubled, on one single day:

image

This is amazing. I’m looking forward to meeting more friends on Signal, so maybe I should prioritize contact discovery a bit now :slight_smile:

13 Likes

There had been remaining files from an earlier alpha (I don’t remember which).

With quite well I wanted to say: “I have not encountered real bugs”. :slight_smile:

One thing, which could be improved (beside new features :wink: ) are the check symbols. In a chat I see two check symbols, when a sent message has been received. They don’t change, when the message is read. I the chat overview I see two check symbols, when a message have been read. This is somehow inconsistent.

1 Like

Right, the config file before alpha.6 was a bit borked due to a race condition. That’s the main reason I broke out a alpha.6 instead of waiting for beta.1 :slight_smile:

Yes, the check marks are a know issue, albeit not really documented why. Should be better after we refactor a bit more!

1 Like

btw: Are attachments supposed to work? Images cannot be sent (never gets received status) and also subsequent messages are not received. When receiving an images, it is not shown. Trying to open it, terminates the app,

They are supposed to work. A few things you can check here:

  • Are you on the latest version, alpha.6? (About screen should show this)
  • Check your .config/harbour-whisperfish/harbour-whisperfish.conf, and ensure that you have:
attachment_dir=/home/nemo/.local/share/harbour-whisperfish/storage/attachments
incognito=false
save_attachments=true

Specifically: the path of attachment_dir should exist. The two boolean values, you can change in the settings view.

Let me know whether the above helps, or if you need more help!

2 Likes

Checked - it is ok.

Interesting fact is that there is no image in the attachments ’ folder, but there should be.

Interesting indeed; is this something you get consistently? If so, could you try to reproduce the issue with verbose logging? RUST_LOG=trace harbour-whisperfish. Keep in mind that the log contains sensitive information; you may want to search for phone numbers and mask them out. Feel free to mail the log to me if you don’t want to post it publicly!

I had the same issue, too. The directory didn’t exist, and creating it solved it for me. Only for subsequental attachments, though.

Also, there is no progress indicator to let the user know when the attachment is downloading and when it’s done.

A .jpg file is saved in the folder in my case at least, so attachments work both ways for me :slight_smile:

1 Like

Creating the directory should’ve been solved in alpha.6, IIRC.

Progress indication is currently impossible, we’ll fix that when we redesign the whole attachment downloading system.

I’m running alpha.6 and the directory wasn’t there.

Actually, I fooled around with the Android Signal app, and ended up removing .share/harbour-whisperfish and .config/harbour-whisperfish folders to re-register, so if the folder is created at install time, it was my own fault :sweat_smile: but the application shouldn’t crash if the directory doesn’t exist, though…

Just checked, it’s not yet in alpha.6, it’ll be in the next release :slight_smile:

1 Like

when allowing the app to find the contacts that are using Signal, it just shows all the contacts that I have in my device. Is that a normal behaviour?

1 Like

Yes! Contact sharing and discovery is still a work-in-progress.

1 Like