Whisperfish - how to register on

I have been using the Signal Android app on this device succesfully for over a year.
But for many reasons I’d like to switch to Whisperfish now.

I start the app, enter my phone number and a password, tap Continue, and it crashes…
This is the terminal output:

> harbour-whisperfish
Config file not found: Could not open config file: /home/nemo/.config/harbour-whisperfish/config.yml
[D] unknown:0 - Using Wayland-EGL
[W] __cpp_closure_14317703314545309294_impl:182 - Failed to load translator for ("en-GB") Searched "/usr/share/harbour-whisperfish/translations" for "harbour-whisperfish"
[W] unknown:0 - "Query failed: no such function: icu_load_collation Unable to execute statement\nSELECT icu_load_collation('en_GB', 'localeCollation')"
[W] unknown:0 - "Failed to configure collation for locale en_GB:  "
[W] unknown:0 - "Query failed: no such function: icu_load_collation Unable to execute statement\nSELECT icu_load_collation('en_GB', 'localeCollation')"
[W] unknown:0 - "Failed to configure collation for locale en_GB:  "
[W] unknown:0 - "Failed to attach key memory region for qtcontacts-sqlite-np: QSharedMemory::attach (shmget): doesn't exist"
[W] unknown:0 - "Failed to open contacts transient store"
[W] unknown:0 - "Unable to open synchronous engine database connection"
[W] unknown:0 - QSqlQuery::prepare: database not open
[W] unknown:0 - "Failed to prepare distinct display label group selection query:  \n SELECT DISTINCT DisplayLabelGroup FROM DisplayLabels ORDER BY DisplayLabelGroupSortOrder ASC"
[D] unknown:0 - Starting favorites query at 499 ms
[D] unknown:0 - Favorites queried in 609 ms
[D] unknown:0 - Starting metadata query at 752 ms
[D] unknown:0 - All queried in 782 ms
==>> I tapped Continue here <==
[W] unknown:0 - "/home/nemo/.cache/be.rubdos/harbour-whisperfish/.mozilla/ua-update.json" parse error "illegal value" at offset 0
greHome from GRE_HOME:/usr/bin
libxul.so is not found, in /usr/bin/libxul.so
Created LOG for EmbedLiteTrace
Created LOG for EmbedLite

I removed all whisperfish directories:

> rm -rf .local/share/be.rubdos/harbour-whisperfish .local/share/harbour-whisperfish .config/be.rubdos/harbour-whisperfish .config/harbour-whisperfish .cache/be.rubdos/harbour-whisperfish

but the result is the same.
What is happening?

I have seen various issues for new users, but surely there must be some way to register?

Or is it possible to migrate from the Android app on the same device?

You are likely experiencing [SailfishOS] Crash during registration (#366) · Issues · Whisperfish / Whisperfish - Signal on Sailfish OS · GitLab

There is a workaround available here: Registration Workaround · Wiki · Whisperfish / Whisperfish - Signal on Sailfish OS · GitLab

Please also see the latest posts here: Whisperfish - The unofficial SailfishOS Signal client - #584 by rubdos


Thanks for the info.
I was able to register with this workaround (you have to be really quick in pasting the Captcha link, first time failed).
Everything is empty, I can see none of my contacts or converstaions or groups.
Is that normal? Will it fill up when I start receiving messages?

The primary app (Android app on same device) asked me to re-sync because something changed, but I did not and closed it again.
My desktop app also wanted to re-sync, so I allowed it. Took a while.
Still, everything is empty in Whisperfish.
I have not tested sending a message because it’s very late here, but I wouldn’t even know how to send a message to one of my groups, they don’t show up anywhere.

It will fill up when you start receiving messages.

In the past I’ve had to ask people to send me the first message to which I replied, and after that the messaging has worked as expected and without problems. I don’t know if the situation is still like that.

I would get rid of the Android app however to avoid having it accidentally hijacking your connection to Signal servers (if it does, you’ll have to start all over again with Whisperfish).

It still is the case.

It should not be possible automatically re-register for the Android app. When you register Whisperfish, it becomes defunct until you explicitely register the Android app again.

@ohnonot , may I suggest you also link Signal Desktop to Whisperfish? It’s a bit hidden in the settings, but that way you’re sure you don’t lose any messages to bugs! With SD, you can also initiate conversations, regardless of the bug in Whisperfish.

Thanks all for replying!

I was able to send a message to myself, and reply to it, between the Linux desktop app and Whisperfish.

Groups and existing coversations still don’t show up in Whisperfish. I have no idea how to send messages to my groups.

I re-linked the desktop to Whisperfish, it looks like before: for some reason it doesn’t show up with its pretty name (“Desktop”) but with a long checksum-like string.
But the linking appears to succeed.

My profile does not show up with its pretty name, only phone number, the avatar appears lost (both on the desktop app and on Whisperfish) and I cannot assign a new one on either app.
Whisperfish doesn’t seem to have a UI for that, the desktop app says “Your profile could not be updated. Please try again.”

I hope there’s some additional info/logs I can supply.

Is this working at all?

I tried several times; yesterday I could see actual usernames inside a group’s member listing, but individual conversations still show up as phone numbers only.

Today all the usernames inside a group’s member listing are Unknown+phonenumber again.

Some attachments/Photos show up, others don’t.

I still see no way to change my phone number to an actual username (as it has been before), neither on Whisperfish nor on the desktop app.

Here’s a (hopefully anonymised) log of a short session displaying the above symptoms

Should I move this to github issues?

Maybe an idiot remark as I don’t know how WF is constructed but I see your phone is using /home/nemo/ and not /home/defaultuser/

1 Like

If you register your phone number anew, you get booted out of all existing groups and conversations, and those users will need to invite you again.

1 Like

Whisperfish doesn’t expose a UI for that, but Signal desktop actually does. You can tap on your user icon in the upper left corner, click on your user, and then you can change your emoji, description and username and profile pic:

Sorry for the late reaction. I’ve set the topic on watching now.

1 Like

Not at all.
I noticed this myself. But only the developer(s) can say if it has any bearing (at least I didn’t see any error messages that might relate to that).

I specifically mentioned that this

  • was set to a username and avatar already, but got lost after installing WF - surely Whisperfish isn’t designed to automatically reset username/avatar?
  • wasn’t possible to change on SD as long as WF was the primary device

OK. But after I registered back with the Signal app I was still in those groups, just like before.

Signal as a system is designed not to retain any information if you register a new primary client, i.e., when you move from WF to Signal-iOS or Signal Android in any direction.

I was recently made aware of this by another friend; it’s not an isolated case anymore! Apparently, we need to upgrade some profile configuration things. Part of that is in this merge request.

1 Like