When VoLTE is active sending sms not possible - SFOS

This seems to be happening only on certain operators, which suggests that the VoLTE modem configs might be wrong for those operators, causing SMS to fail even if calling works. It’s very difficult to reproduce such problems outside of the problem network, so it would be really helpful if someone on an X10 II could see how their VoLTE is configured and see if there are any alternative configurations which might work better.

See this thread for details on where these configs can be found:

For the Xperia 10 III, the modem configs are more self-contained in the modem, and though they could still have issues, it might be much harder to fix.

1 Like

Can confirm this bug on o2.de (Prepaid) and Xperia III.

Cannot confirm with Xperia 10 III,, Vodafone Germany. Works.

The interesting thing is that SMS do not work when I enable VoLTE on my “digitec connect” SIM here in switzerland, but someone listed Sunrise (the same network) as fully working. From my understanding, digitec connect is the same network, just rebranded (when searching / manually selecting the mobile network, the Sunrise network is shown with the “digitec” name on my phone).
It certainly would be interesting, which configuration (modem file and SMSC) the sunrise SIM used. Unfortunately, I wasn’t able to find out who filled in the Sunrise information in the other thread.

Also affects blau.de (belongs to https://www.telefonica.de/)

4G calling (beta) enabled / SMS cannot be sent - only incoming SMS
4G calling (beta) disabled / SMS sending/receiving works as intended

Xperia 10 III - SFOS

1 Like

bug is still there in :frowning:

1 Like

Still sending sms issue using TDC net and sfos 4.5. MMS is possible so ad a picture every time :relaxed:

For some users who have problems with VoLTE, do not upgrade to 4.5.
First VoLTE is not working and when not using VoLTE the other part cannot hear what you are saying – A REALLY NO-GO.
Ei olle Hyvä

New in this.
Here is what I did:
1. Open Terminal and run “pkcon refresh && pkcon update”
2. Login as Root “devel-su”
3. I have zipper installed so run” zypper ref && zypper dup” (zipper uninstalled the lates version of Chum)
4. Run “zypper ref && zypper dup” again and Repositories was changed from Chum to others.
5. Run “version –dup”
6. Restarted the phone
Now the Microphone is working again :blush:
What of above points that did help I do not know, maybe the last point or all points :blush:

After upgrading to 4.5, my issues with sending SMS seem to be solved with the ‘digitec’ (Sunrise) provider. I’m not sure if there was a change in SFOS or on the side of my provider, but sending an receiving SMS now works.

Strange, I may have been to quick on my conclusion. While sending and receiving SMS worked directly after enabling VoLTE, it stopped working some time afterwards. I noticed by chance that sending and receiving SMS was not working a few days later. I also noticed, that the phone switched from WiFi to mobile data when I tried to send a SMS, not sure if this is intended.
So for now, I have to go back to ‘not working’ and investigate further, what the issue seems to be. As I was at a different location when noticing that it wasn’t working, it is possible that the issue may be related to the mobile cell or signal strength (or 3G vs 4G connections).

Can confirm in XIII with o2 Germany on 4.5. Have not noticed it before, because I never tested VoLTE. After the update VoLTE was activated automatically, so I run into this issue. VoLTE deactivated again, fortunately no need for it at the moment and SMS are working.

1 Like

Similar thing happens from time to time (more often than before) after update to 4.5 of Xperia XA2. Sms fails to be sent in 4G. Sms sending is repaired neither after restarting the connection services via tools nor after restarting the phone. It starts to work only if I restart the phone in 2G mode, and then it also works after switching to 4G. It is strange as XA2 has not got VOLTE.

I have 4.5 on an X10III with an MVNO using the German O2 network and I can receive SMS. Didn’t need to send one yet.

Xperia 10 III on T-Mobile Poland:

If VoLTE (i.e. “4G Calling”) is enabled, sending SMS works only on 4G network. Otherwise (i.e. if the network is currently 2.5G or 2G), as long as “4G calling” is enabled, sending SMS won’t work (“Sending…” is shown and then it times out with an error like “Unable to send SMS”).

So if my phone is not on 4G network, in order to send an SMS I need to either disable “4G calling”, or somehow make the device switch to 4G network (e.g. by changing the Network mode option in Settings to e.g. “2G only” and then back to “4G preferred”. Otherwise, the message just won’t get sent.

At the same time, receiving SMS messages works OK regardless of the “4G Calling” setting or current network mode…

1 Like

Same here. if Volte ( “4G Calling”) is enabled cannot send SMSs.
Mobile: Sony Xperia 10 III
Company: Movistar (Spain)

Xperia 10 III on Freenet Germany

Similar: If 4G calling (beta) is enabled, “in order to send an SMS I need to disable “4G calling”, or Otherwise, the message just won’t get sent.”

Same here, Netherlands, Vodafone on X10iii

Same configuration with Vodafone Germany: Works.

Same symptoms on Vodafone UK (have to disable 4G calling (beta) to send SMS)
Xperia 10 III

4G connection indicated when last attempt made

This discussion thread (“topic”) has become a duplicate in a way, because the same issue is tracked for SailfishOS 4.5.0 in this newer thread, in which sailors do reply: