WhatsApp recovery from file system or google drive

SailfishX (Xperia XA2) user here.
I would like to ask, if someone has same strange behavior as me.
After buying XA2 I wanted to restore backup data from Google drive, but I have no options to restore it from GD in WhatsApp. WhatsApp tells me, that there is no Google Play installed.
After that, I’ve tried to do manual restore via this howto:


(copy whole android_storage/WhatsApp directory to XA2, rename database file and then reinstall WhatsApp app).
But after starting app, backup didn’t appear there and it shows me that recovery is not possible.
Am I doing that wrong way?

I have in my notes that one does only need the Databases and Media directories in the WhatsApp directory. You’ll also need to clear Data and give Storage permission in the Android settings.

I’ve restored WhatsApp from Android to Sailfish several times now and this works for me, but it’s fiddly at times. (What I mean is the order of clear Data and giving Storage permissions isn’t always clear to me.)

Install microg, add your Google account,install google drive and then reinstall Whatsapp. It should find the backup now. But when restoring, there seems to be a timeout or similar. At least in latest version. And at least in my case :confused:

What you mean with clear Data? :smiley:
Storage permission … yeah I thought about it, but there were read permission for all, but I can change it to rwx for all for WhatsApp directory :stuck_out_tongue:

Microg? I’ve tried to find it in Android store and Jolla store, even Storeman I found nothing usefull :frowning:

https://together.jolla.com/question/209300/how-to-microg-in-sfos-31/?answer=209744#post-id-209744
(it will take > 1h to install everything…)

Initially I also had problems to restore WhatsApp from android_storage/Whatsapp.
(This was back in April this year, so things might have changed.)

I assume you have

  • restored your data in android_storage/Whatsapp, e.g. using tar.
  • installed WhatsApp android app

Before you start WhatsApp, go to

  • Settings -> Apps -> Whatsapp -> Android Settings
    and allow it to access the file system.

Otherwise, when I just started WhatsApp, it found the backup but reported it with “0 Bytes” and could not restore it.

1 Like

Cool man… thx… that was the reason it didn’t show me backup file :wink:
Thx a lot…

Was restoring really working for you with @dschwert2’s hint?

Yep,

  1. I copy whole WhatsApp directory to android storage from SD card,
  2. install WhatsApp app again,
  3. then go to android setup of WhatsApp app and allow access to file system.
  4. Run app and it shows me last backup from directory :wink:

Iirc you need to start WA once (but not complete the startup phase) to have the
$HOME/android_storage/ WhatsApp
created with correct file system rights.
Like

[root@Sailfish nemo]# ls -al
android_storage/WhatsApp/
total 48
drwxrwxrwx 9 media_rw media_rw 4096 2019-12-08 02:00 .
drwxrwx— 21 media_rw media_rw 4096 2020-06-28 12:52 . .

Note the user and group name.
If not (may happen if you copy over the whole WA directory) then do as root (devel-su)

chown -R media_rw:media_rw $HOME/android_storage/WhatsApp

1 Like

Well, I see in the thread now that it’s solved but I meant in Android Settings -> Storage -> Clear Data. Then you can try again without needing to remove and reinstall WhatsApp.

As I see in the thread, this was the fix you needed :smiley:

1 Like

May I ask if the whatsapp button in this can be removed

I have never been able to restore whatsapp content. With Telegram this works fine, but WhatsApp after a system upgrade or after a reinstall has always wiped it’s crappy own backup on Google drive or whereever they store it. It does not even give us a chance to point to a backup file in a directory view.