Whatsapp groups play notification sound despite Android setting

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product):
HARDWARE (XA2, X10, X10 II, …): X10 II
REGRESSION: (compared to previous public release: Yes, No, ?): yes, compared to the old Aliendalvik 4 on my Xperia X


Whatsapp group messages trigger a notification sound even if it has been turned off in the app’s settings.


Whatsapp installed under Aliendalvik. Member of at least one group.
Phone not on silent, non-empty “Chat” sound in Sailfish’s Settings / Sounds and Feedback / Chat .


  1. In Whatsapp, select Kebab menu / Settings / Notifications / Groups / Notification tone: silent
  2. Get a group message inside one of the groups you are member of.


No sound is played. The notification is still delivered.


Jolla’s “Chat” sound is played.


I would like to be able to silence group chat messages, but still keep a sound when a personal direct message arrives. This is possible in Android, and was possible in Aliendalvik 4 on my Xperia X.

Open the SailfishOS Settings app
Go to Apps / WhatsApp / Open Android Settings
In the android settings app that appears choose Notifications and turn off Group Notifications

Does this help?

Um, but I do want Group Notifications to pop up on my screen. It’s just the sound that I want to mute. I’ll try that setting, but it looks like it does a different thing. [EDIT: yes, confirmed]

Noticed the same behavior when I still used whatsapp on my Jolla1. Didn’t consider it bug but rather a limitation caused by the way sailfish handles android notifications. I have understood that SailfishOS has a list of android apps which trigger notification sound allways when they make a notification. Other apps just don’t. Notification sounds are not handled on Android side so they pretty much can’t be modified there.

1 Like