Whatsapp download page makes sailfish browser to crash

WhstsApp does no longer work on sailfish.

sony xperia I and sfos


click on download, for me the browser says either wait or close. On wait nothing happens, only closeing works.

Whstsapp refuses to start because of not the newest version.

I confirm. A new tab is opened and nothing more happens.
Must be something new in the web-code because a couple of weeks ago it worked flawlessly.

However, there is a workaround. You can download it from a PC browser and copy the apk file to the phone via cable.

1 Like

Iā€™d suggest to use Aurora store to tap into the google play store: https://f-droid.org/de/packages/com.aurora.store/


Only a small note from my side. I downloaded the apk with browser by clicking the link in Whatsapp just this morning. But I have Xperia10II with 64 bit system on So maybe the different architecture makes the difference?

worked very well. cheers bernd

switching to Xperia 10II is something I should have been done already, but did not ā€¦

the Aurora store is very helpfull for Android Apps :grinning: I did not know about this one.