Weird battery issue

Xperia III running the latest update.

About 10 days ago I noticed my battery didn’t make a day. Plugged it in, came back an hour later and it had fully discharged. Put it on a different charger, charged to 100%, went on. Plugged it in that night and when I got up the next morning it had been discharging, not charging.

Happened a couple more times mixed in wtih a few days of no issue. Now I notice it only charges when the phone is turned completely off.

This leads me to believe this is a software glitch of some sort, but I have no idea who, what, where, or when to even begin looking.

Anybody have the same issue or a suggestion for a fix that does not include "reflash the OS’?

Are you using any apps to control charging, such as Battery Buddy? Or the SFOS default battery aging protection?

I believe around a week ago I ran into a same kind of problem, where I couldn’t charge my phone until I quit the BB service or turned the phone off.

No, no battery buddy or aging protection.

On my X 10 I use Battery Log (which is open by Situation app when charging) to check charging current as it seems that sometimes contact and/or cable doesn’t provide any/full capacity current.

You can check your charging current with one of the apps too just to be sure what the cause is.

Perhaps SystemDataScope app by Rinigus (see at Storeman or Chum for download, GitHub - rinigus/systemdatascope: SystemDataScope is a GUI for visualization of collectd datasets) could help to figure out what the issue is.

1 Like

In general, ageing protection for the phone’s battery is a good idea if you want to be sustainable. SailfishOS system feature for this is excellent in comparison to the duopoly’OSs (Android/iOS) as they do not support such detailed settings, e.g. in iOS it doesn’t stop changing at the threshold value at all. Also, it seems like they want to sell the user soon again a new iPhone.
However this ageing protection is not the cause of your issue. It’s rather a feature everyone should use unlike you want to replace your battery soon.

That could be damaged cable or connector. Try a few cables, both way around, and check PC connectivity too.

I did a little bit of presearching and found a thread on Sony support site, where one person had similar symptoms (with a different phone) as @Glockdoc. In that case, service replaced the whole phone instead of the charging port that was seemingly the faulty part.

But before jumping to conclusions, it is of course good to check what has been proposed above!

Tried several cables and bricks. Will try PC charging today.

Just installed. I will see if I can learn anything from it. Thanks for the suggestion.

Currently plugged into my pc and just flashed “not enough power to charge” and battery percentage has gone down. Not a deal killer to turn it off and charge it at night, but 1 more hassle to use linux mobile. Probably ordering a Pixel 6 and installing Lineage w micro G next week.

Does your USB cable fit correctly in the phone? Does the cable ‘lock’ in the phone?

I have tried several. Have not noticed any fit issues. They are charging other devices fine.

When I plugged the cable in the dialog box popped up to ask what mode I wanted. I am assuming the fit is fine.

I had a simmilar issue a few months ago. Connected the phone to the charger, the os reported that a charger is connected and the charging symbol was shown. But it didn’t charge. Battery Buddy also showed that it is connected but no current from the charger. After cleaning the charging port with a toothpick the cable fitted in alot better and charging worked again.

Thank you, I will give that a try.

That pop-up shouldn’t appear with a dedicated charger. If it does, that usually indicates either an incompatible charger (one that doesn’t adhere to the USB battery charging specification) or a bad connector/cable where the USB data pins don’t connect properly.

With USB-PD-charger (Sony branded) after the latest update ( on 10 III) it actually does that. Someone else here also reported this.