WayDroid on SFOS?

camera yes. I think the last I read was that location not working, and I noticed that it doesn’t show accurate battery level (it’s always 85%). A few little things like that. For the most part pretty solid…


Location works now with waydroid-sensors installed. Pretty much everything works to be able to run the few Android apps one might wish to on a Sailfish device.

No banking apps and DRM content though.


@lal Sorry if i talk bullshit. But wasn’t Jolla talking about a signature for Android apps in a future release so that f. ex. banking apps would no longer signal a rooted device. Couldn’t that be integrated in Waydroid? :slight_smile:

I dont think so. AD is way ahead and more stable. Furthermore, despite the fact I would prefer SFOS on a FP4 than the X10 III, I would go with the official port/license because community ports/projects get abandoned often fast.


Oh I didn’t know about that. Is that same stuff as what micro-G does? I am not familiar with any of those, to be honest. Also Waydroid does not advertise itself as rooted to the apps from what I understand.

1 Like

@lal Look at the video with Joona Petrell, at minute 43 he is talking about a “signed system init”!?

But probably he refers to the Jolla App Support rather then SFOS in total if i am not wrong…

PS: I found the information i was talking about:
“Improved Android App Support. Sailfish OS 4.3.0 will have a signed system image for Android App Support. This should allow apps that previously complained about not running on a rooted device to work correctly. This should, for example, allow certain banking apps to run that previously refused to.”
This was stated in the latest community news here: Sailfish Community News, 21st October 2021


AFAIK these are different. Android app of bank I’m using complains once per an install or update that device is rootet but works anyway, but refused to work with out microg.

1 Like

Interesting, I don’t get gps with that (I do get e.g. orientation). Do you have a specific gps output in wayland log from the sensors daemon?

I just checked the log, there isn’t anything specific to GPS there from waydroid-sensors. GPS started working for me ever since I installed it (from chum repo), so assumed waydroid-sensord fixed it. Probably something else then!

Actually it seems to be working after I’ve installed Here WeGo! Lime in its own somehow wasnt triggering positioning.

I would also like to add that I really appreciate the sailfishos-open packaging for this, great work!

Here WeGo! Beta seems to get a half decent location with just an internet connection and location turned on, on my Xperia 10 II. I have yet to install any MLS packs or even go into the location settings section (I just turned it on from the top menu).

I notice that waydroid eats more battery than usual on the fxtec pro1. Anyone else having this problem?

Endurance before and after Waydroid looks more or less the same. But then, I don’t let waydroid apps run in the background. Also, felt like running media in Waydroid consumes fair bit of energy.

1 Like

@lal - question for you, (or anyone [@rinigus])…

When Waydroid was first released in Chum, I already had it installed from your repo, so I just installed the packages from Chum, and dleted my previous Waydroid init directory, etc, and it went on functioning fine.

Now, I’ve clean-flashed, and I installed from scratch using only Chum. Everything works fine, bit there’s no icons, (no Waydroid icon, and no app icons), in the SF app drawer.

I noticed that the file structure is quite different, with Android data in ~, and Waydroid directory in /opt. Maybe this explains it…

Anyone else who’s installed via Chum experiencing the same, or just me?

I’ve installed Waydroid (and also waydroid-settings) from chum and it works just fine.

@Levone1: have you checked README at https://github.com/sailfishos-open/waydroid ?

In this version, Android apps are exposed to SFOS launcher. Waydroid launcher you should get if you follow the README


Thanks @rinigus and @piggz or the integration with systemd scripts. Just as @levone1 I have reused the waydroid install from before chum packages.

What I notice is that if the show full ui fails, clicking on one of the previously created desktop files makes show-full-ui work again next.
(I have not debugged why)

if you execute “waydroid prop set waydroid.active_apps none” after closing the UI and give it a few seconds, you should be able to bring full UI up again.

As I understand it, from conversation in waydroid channel, waydroid doesn’t yet understand if its window is closed in Sailfish OS which would have otherwise run the above command automatically and allowed the UI to be restarted.


Restarting ui working fine for me using waydroid-settings package, after clicking ‘stop daemon’ then short wait and ‘start daemon’.

Anybody else tried GMaps? For me, just opening the app breaks location fix instantly. When the app opens, it shows map with accurate location fix, but then gps fix breaks, and it’s just stuck there. Then, when I close or even just minimize the app, fix comes right back instantly. I did it back and forth 10 or 12 times, and it was consistent …