Waydroid and internet problems


I’ve got a problem with waydroid in my xz2 compact, since some versions ago, and I don’t know how to fix it, when I’ve got waydroid runing, my mobile is unable to connect to any new network. I will try to explain myself:

When the mobile has internet connection, and I start waydroid, everything works fine, but at the moment that this internet connection expires (dhcp expires, network disconected, whatever) the mobile is unable to connect again to the network, stop waydroid and 2~3 seconds later everything is connected again. (The easy way to replicate it is with airplane mode)

Somebody has any idea of what it can be? how I can fix it?


You need to disable dnsmasq.

And you have to edit /etc/gbinder.d/anbox-hybris.conf as devel-su.
Change aidl2 to aidl3, it occurs 4 times
the third lines of the 2 blocks: hidl leave as it is.
Then save file.
Then reboot and start waydroid.


Thanks for your answers but unfortunattly:

@mankir I already commented the binder line in the dnsmasq, or you mean to fully disable from systemd?

@Seven.of.nine I don’t have anbox-hybris.conf I’ve got a waydroid.conf in that file, and the aidl is already 3. I did all this stuff when I get working waydroid originally almost one year ago.

Thanks for your answers,

Disable with systemctrl, i guess…

There is also this command:
systemctl disable --now dnsmasq
(as devel-su)

done that, everything is still the same :frowning:

I will end formating the phone which I don’t wish to do.

I’m very surprised that the file /etc/gbinder.d/anbox-hybris.conf doesn’t exist at this location (path) on your xz2 port. I wish you good luck @jsingla !

I investigated more today, I was connected to the device via ssh, and it looks like sailfish, has some kind of priority for networking, and tries to connect first the more priority, and then the less,

For what I tested, seen today, looks like waydroid virtual network goes to top priority, and with that sailfish doesn’t try to connect anymore to the other networks (wifi or mobile data). In more detail, seems that waydroid creates a network called “veth3xk8AE” and this one is the one that fucks up my networking. (and of course, waydroid setting that network down, doesn’t have internet :frowning: but it has another virtual device called waydroid0)

Anybody has any information?

Anybody knows if there is an app in sailfish that allows to disable and enable network devices like the ifconfig/ip command of linux? That will be able to workarround this problem pretty easy.

You can use /etc/connman/main.conf :slight_smile:

NetworkInterfaceBlacklist = p2p,usb,rmnet,rev_rmnet,ccmni-lan,wlan1,wlan2,ifb0,ifb1

EDIT, on Volla-like devices it’s main-mtk.conf. EDIT 2, but that’s not what you want. Or?


Not sure what it does the blacklist, since I don’t know too much connman, I tried adding the other network there, and seems now waydroid created a different network device :S and making the problem don’t being fixed :frowning:


The blacklist would keep connman from using / bringing up that interface. But it’s it’s brought up by waydroid, that won’t make any difference. I’m just wasting your time, sorry!

It’s noted that as
Note that starting from SFOS version 4.5 release of this port, Waydroid gbinder configuration is included with the rest of device configurations. So, **do not install** `waydroid-gbinder-config-hybris` package on your device.

Is this maybe a issue from an older install? Ref: GitHub - sailfishos-sony-tama/main: Documentation, releases, and issues

Well, all comments are welcome, don’t worry.

I just double check, (I was thinking that it was not installed)and yeah, waydroid-gbinder-config-hybris is not installed. Is it a way to check which files create, maybe I’ve got some old files from before the upgrade?

After the tests that I did today, I’m thinking part of the problem can be lxc, since he created a different network when I blacklisted the old one (Well, I expect lxc created it) also, my expectation is that waydroid is using the interface network waydroid0 not any other.