VPN "forget" and "Add new VPN" ignored

REPRODUCIBILITY: 100%
OS VERSION: 4.4.0.64
HARDWARE: Xperia XA2
UI LANGUAGE: English
REGRESSION: Yes (Though it was already there in 4.3 but I could add those VPN at some point so it’s technically a regression but I don’t know from which version)

DESCRIPTION:

It’s kind of similar to [4.4.0.58] Bug: VPN "forgets" config and creds after reboot but goes a bit further (I don’t know if it’s related or the exact same bug or something else entirely):
I have a bunch of ProtonVPN as OpenVPN files and some server are about to be removed and they have new better files so I tried to clean everything and add the new one. unfortunately once I forget everything if I try to enable/disable the new server the entire list revert to it’s previous status.
Also similarly to the one I linked before if I try to “forget” everything and reboot the list is also reverted. I’m left with no options to add or remove any VPN.

PRECONDITIONS:

OpenVPN files and a pre-existing vpn list

STEPS TO REPRODUCE:

  1. Forget all vpn in the vpn list in settings
  2. Try to add a new one
  3. Enable/disable the new one (or try reboot)
  4. see the list reset to its previous state

EXPECTED RESULT:

The VPN list doesn’t revert to its previous state

ACTUAL RESULT:

The list revert to its previous state

MODIFICATIONS:

No patch at all.
installed OpenRepos: Mattermost, Piepmatz, Puremaps, Patchmanager

ADDITIONAL INFORMATION:

I could provide a strace or a similar tool to give you information about read and write access but it seems strace isn’t a part of the default binaries. Please tell me if I can provide something that could help you.
Note: I’m used to Gentoo (on my desktop) which doesn’t have systemd (by default) if I missed any logs that could have been provided by it please tell me.

Additional notes

I also couldn’t find where this VPN list is stored, I tried to search in .local and dconf and check if there is any path in the QML files but couldn’t find one. If you could point me where is the setting file so I can edit it myself to workaround the issue that would be awesome.

1 Like

There is at least ~/.local/share/system/privileged/connman-vpn/ but I don’t know if thay’s everything.

Thank you, it did help!
I also discovered there is a bit more to that bug:
By clearing the folder and try to re-add my new openvpn severs it seems that on my 4 new one 1 worked and on the others nothing is created, no file, no folder, nothing. my intuition tells me there is silent error somewhere maybe a unsupported OpenVPN feature ?
If that’s the case I’m using ProtonVPN with generated OpenVPN files with files designed to handle multiple server in a specific country.
More specifically the one that worked was the Swedish server but Icelandic, French, Finnish once didn’t.
I hope it will help the jolla team even further to reproduce and find the issue.

Could you share one of those files possibly?

A lot of information in those files are specific to my account so for a lot of security reason I’d rather not.
That being said it is possible to create a free account yourself and generate files openvpn files in the same manner I described.