VPN doesn't work



when VPN is activated no app is able to connect to the Internet. No connection via mobile data or wifi is possible


VPN worked like a charm in


  1. activate mobile data or wifi
  2. connect to a site via browser, firefox etc. to verify that the connection is possible
  3. close browser, firefox etc
  4. activate VPN
  5. start browser, firefox etc and go to previous site → no connection possible


conncection to internet should work with / without VPN


connection to internet just work without VPN




What kind of a VPN is it, and it ist set up to use a default route?

Does it support IPv4, IPv6, or both?

1 Like

it is a openvpn (protonvpn, paid version)
yes, it is set up as default route.
on the Sailfish VPN menu it claims that it is connected

just did some tests and it’s going to get curious:

  • SFOS Forum app doesn’t work
  • SFOS Browser doesn’t work
  • SFOS Mail app doesn’t work
  • Firefox doesn’t work
  • Telegram works
  • ProtonMail app works
  • GEORG Sparkasse app doesn’t work

As i wrote, in everything worked fine.
i also deleted the config and created the connection new with same result

Hi, while I made my paid Proton VPN (IPv4) working on X10 iii, with my IPv6-only ISP provider (another story of SFOS 4.5 elsewhere in this forum), I took some notes for debugging the VPN connectivity issues, which you may find useful. FYI, after upgrade to, ProtonVPN still works.

1 Like

I’ve also had some issues with VPN (paid proton VPN also) since and but they differ a bit from the one described in the 1st post.

My VPN connection works fine and both sailfish and android apps work as intended. However, when the phone has been idle for a longer period of time (hours? Every morning at least), the android apps seem to be without a connection. The sailfish ones still work.

My quick and dirty remedy (not an actual fix) is to disable VPN from the top pulldown menu and and the android apps immediately gain access. After that I enable the VPN again and everything works perfectly. Really annoying but manageable when one knows what to do.

played around yesterday with deleting all the VPN configs, several reboots and reconfiguration of VPN. Suddenly it worked with all apps.

I turned off wifi and mobile data for several hours. Than i activated wifi and VPN with the same result as described in my second post. After this i deactivated wifi and went with mobile data and VPN. Since then all apps have internet access via VPN.

So it seems, that after a longer time period without inet one has to activate mobile data and VPN first, than wifi should work also with VPN.

i’ll check again tomorrow and post the result here

Tested on data only. XA2., ProtonVpn, IVP6 disabled.

+/- the same here.

Fernschreiber (SFOS native Telegram client) is permanently working with ProtonVpn enabled.
Hotspot (Firefox on PC): Some sites work (the forum here), some not (whatismyip.com).

Stock Browser not working.

it seems some timeout / idle connections cause the problem. In my case VPN with mobile data does work, the problem is more on the wifi side. i have a workaround now that works at least for me:

  • activating wifi than as second step activate vpn
  • disconnecting vpn first than disconnect wifi (so that the vpn doesnt start automatically with wifi)
  • if i forgot to disconnect vpn first and vpn connects automatically than disconnect vpn, disconnect wifi and then start wifi first, then vpn.
  • also possible is to change from wifi + vpn to mobile data + vpn and back

I don’t know if the following should be done, or not, in the present particular case…

But I installed the packages related to CLAT discussed there:
and my ProtonVpn connections seem to be working now.
IPv6 disabled in VPN settings because of leaks. Tested with https://ipleak.net/.