VoLTE provider support

Same here. I kept getting messages from EE (Optus) in Australia telling me my area was 4G calls only, so please could I enable this feature on my phone. The 4G calling light just kept blinking forever. EE VoLTE works fine in my home country of the UK.

AT HOT xperia 10 ii, not registered

Hello, I tried these steps from: Sailfish 4.4 T mobile network denied

And that resolved the “denied” status! And the phone is back on T-Mobile network.

(I tried this on Sony 10 Xperia III, after trying the SIM card on another phone; and then replaced the SIM card with a new one, and “denied” status did not change)

# Make sure repositories point to right version
devel-su ssu re
devel-su ssu rr adaptation-common
devel-su -p pkcon refresh
devel-su -p pkcon install ofono-ril-binder-plugin
# Reboot device
devel-su -p version --dup

Of course, update the version number in “$ devel-su ssu re” to proper one.


Would it be possible to provide what settings you do have MMS settings, and data access point settings, and other settings to have MMS work for T-Mobile on Sony 10 Xperia III, in the US?

MMS is not working with my Sony on T-Mobile service, not sending nor receiving. And I do not mind going with Red Pocket, already have a service with them.


This solution helped:

don’t get this:
i shall create a folder with S139.1 ok
then create modem.conf in it ok
but how should the content of that file look like ?
just some
…/…/firmware_mnt/image/modem_pr/mcfg/configs/generic/euro …

and if i cant find hot nor magenta in generic/euro/ what then ?

Sure. See screenshots below from my 10 ii. Red Pocket GSMT (T-Mobile SIM).


1 Like

Updated the Wiki with my testing on Vodafone Romania, for some reason I can’t send SMS with the setting on, but otherwise it’s fine - shows Registered, can call, can be called, can receive SMS.
I have an Orange Romania SIM available also, so will update when I get the chance to try it.

1 Like

What would be the setup for Red Pocket Mobile in the US for GSMT?

**And what directory should one create besides the two aforementioned?

Thank you,

Red Pocket Mobile GSMT APN Setup:

Name: Red Pocket Mobile


Proxy: Not set

Port: 8080

Username: Not set

Password: Not set

Server: Not set

MMSC: http://wholesale.mmsmvno.com/mms/wapenc

MMS proxy: Not set

MMS port: Not set

MCC: 310

MNC: 280

Authentication Type: None

APN type: Default,mms,supl

APN protocol: IPv4

Bearer: Unspecified

Updated the Wiki with my testing on Orange/Yoxo Romania with the same results as Vodafone Romania - shows Registered, can call, can be called, can receive SMS, but can’t send SMS.

In both cases this was with default settings, but given that the SMS Message Center has only one address for both sending & receiving, not sure if it’s an issue on my end.

Xperia 10iii, MTS (МТС - Мобильные Теле Системы) - enable VoLTE, then ask provider enable it in my service plan (its free), and after reboot seems it work.

1 Like

@flypig should we create separate bug reports for issues?

(like the one i replied to)

1 Like

Sorry for missing your original query @thigg and thanks for flagging it up. I think creating a separate report would make sense. It may be that there’s a need to run some tests or collect logs, and having a place to discuss that is always useful.

Have added Telia / Phonero and the 10 III over things that are OK.

And due to my use of . in stead of - in the date (Norwegian grammar) the list is now slightly easier to read (i think) :upside_down_face:

While on vacation, I gave Ooredoo Tunisia a go, but it doesn’t register, just blinks when selected (at least on default settings and on prepay). Updated the Wiki.

I tested my Xperia 10 iii on T-mobile in Tampa FL (USA) region and VoLTE works fine for voice and SMS. This is on SFOS


Thank you for sharing

On my Xperia 10ii/O2 Germany VoLTE works fine for incoming calls, but for outgoing calls there is still some funny behavior: Sometimes the phone does still switch to 2G, most of the time it does not. Sometimes, there is a calling tone, most of the time there is not. Sometimes, the entire network stack crashes after calling/calling attempt, and, guess what - most of the time it does not:-)
Just my 2 cent


Can you try to collect logs after this happens?

Yes I will try. I have to find out again how to do this first, though;-)