VoLTE on the Xperia 10 II - filling in the gaps

Thank you so much for your experience, I am using 10 III and the paths for Polkomtel are slightly different.

mkdir -p /vendor/oem/modem-config/S185.1
echo -n "/vendor/firmware_mnt/image/modem_pr/mcfg/configs/mcfg_sw/generic/EU/Polkomtel/VLVW/Poland/mcfg_sw.mbn" >> /vendor/oem/modem-config/S185.1/modem.conf

The weird thing is even after creating that and rebooting, I still can’t enable it. Any further steps I should do? I will wait and hope it will start working, I hope if X10II worked III will too, but this phone was never sold by them.

I don’t know if the same mapping can be done in case of xperia 10 III - I doubt that, but maybe someone else can shed some light on it . Nevertheless I suggest you to enable volte explicitly - if you haven’t done it already. It is done by sending SMS message ‘WlaczVoLTE’ to number 2601 (for postpaid) or by shord code *101*11*1317# (for prepaid).

Both xperia 10 II and III are not officialy volte supported phones by polkomtel according to their website. Xperia 10 II works with volte, so chances are the 10 III may also work.

1 Like

No, the X10iii doesn’t look at those modem.conf files at all to my knowledge. The choice of config is automatically selected internally by the modem. So messing with those on a III won’t do anything.


Thank you a ton, now it works!
Also thank you @abranson, interesting!

Have you figured out which files are responsible for VoLTE on 10 mk II ? I would like to try to transfer files from 10II to the TAMA port for XZ 2 compact (works fine with android VoLTE) . I am grateful in advance .

1 Like

I got Elisa EE working with:

1 Like


Nice. I still haven’t gotten Telia EE to work.

This worked for me for Comviq (Sweden):

  • SIM config ID: S55.3
  • Config file: mcfg_sw/generic/euro/tele2/vlvw/swe/mcfg_sw.mbn

For completeness (since I refer to this page on the VoLTE provider support page)
This is what I did to make Telavox to work on my Xperia 10 II.
I put in my complete SIM card number since I don’t know if a particular prefix should be used but I think someone with more knowledge of these things can use this as a starting point at least.

[root@Xperia10II defaultuser]# diff -u /usr/share/sony-modem-switcher/service_provider_sim_configs.xml.org /usr/share/sony-modem-switcher
--- /usr/share/sony-modem-switcher/service_provider_sim_configs.xml.org
+++ /usr/share/sony-modem-switcher/service_provider_sim_configs.xml
@@ -297,7 +297,7 @@
   <service_provider_sim_config sim_config_id="S54.1">
-    <sp>Telia</sp>
+    <imsi>^24001XXXXXXXXXX</imsi>
   <service_provider_sim_config sim_config_id="S55.3">
[root@Xperia10II defaultuser]#
1 Like

@flypig The Jolla Shop still claims that Xperia 10 II does not have VoLTE beta, although it does. Shouldn’t it be updated?


You’re right, it should! Thanks for pointing it out; I’ll raise it on Monday.


This is still to be done, but I’ve not forgotten about it.

Thanks again for pointing this out @direc85. The Shop page has now been updated. Please say again if you notice anything else.

1 Like

Has anyone in the US figured out how to get VoLTE working on the 10 ii with AT&T based service? I was successful in getting T-Mobile service to work using hackman238’s instructions (modem config). I have a Red Pocket AT&T SIM (GSMA). Data and text messages work, but no phone calls. VoLTE does not register (continues to blink). I do not have to worry about the AT&T whitelist because Red Pocket seems to bypass that even though they are using AT&T service. I believe the phone just has to be configured for AT&T similar to what was done for T-Mobile. If someone can help, it would be appreciated. Thanks.

I’m also in the USA and use a AT&T backed network (PureTalk) using a Xperia 10 ii. While text and data work as expected, calling doesn’t work at all. I also get the same “VoLTE not registered” with a continuous blink. If anyone knows how to fix this issue, please share.

I also have a non-VoLTE-registering Hallon. How did you get the correct modem.conf into the right place on your phone?

I tried to suss out what I needed to do based on your post, but while I’m able to create a directory to hold a modem.conf file, I’m not sure what I need to do to get the correct Swedish “hutch” configuration into there. I saw that there was an earlier hutch reference, and thinking that perhaps “hutch is hutch”, I gave that a whirl, but no joy getting VoLTE to work yet.

What I tried…

[root@Xperia10II-DualSIM ]# mkdir /vendor/oem/modem-config/S9105.1
[root@Xperia10II-DualSIM ]# echo -n "mcfg_sw/generic/euro/hutch/vlvw/uk/mcfg_sw.
mbn" >> /vendor/oem/modem-config/S9105.1/modem.conf

As of now I don’t remember. I will have to retrace my tracks…
Will be back.

Thanks. Much appreciated!

As a start as su/root:

getprop persist.vendor.somc.cust.modem0

Gives me the ID: S9105.1

cd /vendor/oem/modem-config/S9105.1

Gives me: No current config for this ID exist.

As I knew from the @tw1 hint that I should look for “hutch” as the name for 3/Tre/Hallon I did a check:

ls -l /vendor/firmware_mnt/image/modem_pr/mcfg/configs/mcfg_sw/generic/euro/hutch/vlvw/swe/mcfg_sw.mbn

As this did exist I went on creating a S9105.1 folder:

mkdir /vendor/oem/modem-config/S9105.1

Next create the config file:

echo -n “mcfg_sw/generic/euro/hutch/vlvw/swe/mcfg_sw.mbn” >/vendor/oem/modem-config/S9105.1/modem.conf

After this i rebooted and where able to enable VoLTE.


Yesterday i switched from Hallon to Vimla! (both in Sweden) hoping to be able to get mms working again.
Had some real issues getting the proper settings for mobile data and mms, so I have been at 3G only until this afternoon. Currently still no mms but at least I’m on 4G again. Have a look at the attached pictures for my current settings.

When I had my 4G connection working i did replace my current “hutch” with “telenor” as Vimla! is running on the Telenor network.

echo -n “mcfg_sw/generic/euro/telenor/vlvw/swe/mcfg_sw.mbn” >/vendor/oem/modem-config/S9105.1/modem.conf

After a while i had VoLTE enabled.
Not quite shure that I actually had to replace the file as I got VoLTE enabled with a Telia SIM without replacing the file. Maybe they are all included in each file… Perhaps someone here knows?
Where not able to test the mms functions with the Telia SIM as the preloaded amount where almost zero.