Vendor Image v17 Limiting Camera's full Potential - XA2

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.0.1.48
HARDWARE (XA2, Xperia 10…): XA2

DESCRIPTION:

Device originally flashed with Sailfish X v3.4.0.24 with Vendor Image v16, updated to 4.0.1.48.
Few weeks later, I upgraded v16 to v17.
Eventually, I kept v17 and moved on.
I Installed Advanced Camera & Open Camera, to unlock the cam’s 20MP.
But 17 MP was the highest available. Even tested with a bunch of random android apps and I got the same result.

I refalshed the old v16 vendor image.
20MP - 5984x3392 is available again. Tested with both A/M applications.
To confirm reproducibility, upgraded and downgraded again. Same result.

PRECONDITIONS:

»»»» Having Vendor Image v17 Flashed

*In this particular case, it was an upgrade, done at a later time.
Users having originally flashed v17 could maybe weigh in?

ADDITIONAL INFORMATION:

Advanced Camera crashed regularly back then, almost every time. Now on v16, so far, no crashes. Could also be related ?

2 Likes

This doesn’t sound like a Sailfish OS bug, but a Sony one. It is recommended to use v16 images anyway because the v17 also break something in wireless networks of 5GHz

I agree about the v17 image breaking the 5GHz wireless bands - I initially tried my XA2 with v17 (coz I thought the latest would be the best) before going back and reflashing with v16. However since these are Sony binaries on a Sony phone I think its fairly unlikely that they would cripple their own camera on their own product - especially when the XA2 is actually advertised as having a 20MP camera. If this were the case they could be sued here in the UK under the Consumer Rights Act 2015 for selling a product that didn’t match its advertised specifcation. I’ve not done any measuring, but when I used my XA2 as an Android phone prior to installing Sailfish the camera took noticeably better pictures. I am therefore of the opinion that this is a Sailfish bug.

1 Like

I believe it has a 23 Mp camera and advertised as so. But I absolutely agree, most likely it’s coming from Sailfish’s side.
Just like Sailfish has failed somehow to utilize the full 23Mp with v16, it wasn’t able to utilize more than 17 Mp with v17.
Moreover, my XA2 was running on LOS17 for a while and AFAIR, LOS didn’t have this issue.

Apologies, you are of course correct here - it does have a 23MP camera and not a 20MP camera.

1 Like

This is not on Sailfish’s side- it is Sony that doesn’t provide the drivers. This has been a known issue with other devices, too.