Usb-otg help (Xperia X)

Having issues with usb-otg on Xperia X. Here’s the gist:

Using SanDisk Extreme SSD. Originally got no response whatsoever when connecting to phone. Booted to Android recovery, (TWRP), and usb-otg mounted easily, and disk files accessible. After rebooting, disk showed up in Settings “Storage” section as unsupported, and only option was format. I installed usbstick utils and exfat-utils from Openrepos, and then the files showed up, and the disk was mounted at /media/usbstick, BUT it still showed the same in Settings. Being curious, I started uninstalling and reinstalling things to try to figure out what was making it work, but now I can’t get it to work anymore, no matter what I install. Also, my sdcard won’t auto-mount anymore. I think I screwed up some system files somewhere by installing and uninstalling many packages…

Attempting to mount manually, (mount /dev/sda1 /media/usb) results in “unknown filetype exfat”. Manual mount had worked one time before - I guess I messed up exfat support somehow . I installed exfat-utils and fuse-exfat from Openrepos, and have tried it with, without, and with different combinations of the various programs, but never working anymore.

Fs is exfat, labeled as hpfs in fdisk -l output.

Any ideas? Thanks


I fixed auto mount problem- I found out by extracting contents of Jolla udisks2 rpm that a file was missing, /lib/systemd/system/mount-sd@.service. Must have been deleted by one of the programs I installed… So I replaced it. Still can’t figure out how to get my ssd to mount…

Was able to mount manually using mount.exfat command from olebr’s fuse package. If anyone has ideas which file in Jolla sysyem is the one that is supposed to auto-mount exfat, let me know.

1 Like