USB-C Ethernet adapter

Hi,
Today I tried an USB-C Ethernet adapter on my Xperia XA2 Ultra.
It works and Ethernet interface is up.

But … in native browser, few tabs work normally and others ask for Wifi or 4G. Android apps ask for wifi (no internet detected).

It seems that the flag « network available » is managed only on wifi and 4G. What if this flag can be managed on ethernet interface too ?

(I tried HDMI output too as the pinephone, but it doesn’t work)

3 Likes

Which adapter are you using? Last time I tried the phone didn’t even recognize my adapter as an network interface.

PS: sorry I can’t help you with your problem. But welcome to the forum!

I used a CGV hub usb-c 51 … it seems to be unavailable.
The most close is is this one :

1 Like

I’d guess that the awareness of a network connection is managed by conman and conman doesn’t observe that ethernet interface. In my previous SFOS upgrade process it happened that Silica didn’t start anymore and I could only connect through USB from my desktop. I set up routing on the phone but tools like pkcon didn’t work because they reported that conman said it had no internet connection.

So I’d suggest to figure out how to tell conman to observe your USB-Ethernet interface.

1 Like

In ’ /etc/connman/main.conf’ there is the following line:

NetworkInterfaceBlacklist = p2p,usb,rmnet,rev_rmnet

Maybe that’s why it doesn’t work.

4 Likes