Update to 4.2.0.21 needs downgrade or removal of some files

Xperia Xa2 with Kvarken:
When trying to update to 4.2, I get this warning: please restore to original version or remove libnice, glib2 & libselinux or there might be trouble with the update.
I don’t remember having changed these files. I tried to remove them in storemanager, but they remain there … . What is the best way to go from here?
Thx for a reply!

1 Like

You can safely ignore the warning for anything you didn’t install yourself, it just means the files don’t match the expected version or something, but the update process will/should take care of everything.

5 Likes

I was able to do the upgrade, thx!

1 Like

I had a similar, yet funnier warning today while downloading the update to 4.2.0.21.
In my case, it seemed that every single default package was listed. I had to scroll several times to see the end of the list. Note that I own an Xperia 10, so my screen is pretty long.

Executing pkcon refresh didn’t seem to make a difference.
To be fair, I updated from 4.1 to 4.2 right after updating from 4.0 to 4.1. Still, I had checked if any app needed an update and rebooted in between.

Anyway, I am happy to say that updating to 4.2 worked flawlessly (as far as I know) despite the ominous warning.