Update to 4.0.1.48 works only on two of four Sony Xpe.. devices

Hello,

we have four Sony same devices. On two of this work the update to 4.0.1.48 fine. On the two other can’t find the new version. Why?

I have prob on this “no new version found” devices the following steps:

devel-su ssu re 4.0.1.48
devel-su version --dup
reboot.

and

devel-su

ssu dr customer-jolla pkcon refresh version --dup reboot

but the result ist the same, no new version are find.

What can I do? About information I’m happy.

Greeting Markus

Do the four devices have all the same Jolla account? If not, is the Early Access option active for all of them?

Hello,

many thanks. We have bay the 50€ for every device (4x), and every device have a separate account. On not device we have activate the android option, all only sailfish native.

Greting Markus

sebix asked if you switched Early Access on, through your Jolla account on their website. If you don’t have this, the update will only be available when it is made public.

Tok, tok, tok, Early Access option?

2021-02-16: 4.0.1.48 was released to all users (Jolla C, Jolla Tablet, Xperia [X, XA2, 10], Gemini PDA) as an over-the-air update.

Hello,
many thanks. All devices have the same “Access on”. Should I check the Jolla account status on the problematic devices?

Greeting Markus

If you have zypper installed on the phones, you could try what zypper up and
zypper dup says, but doubt it will be much different from version --dup.

Hallo,

thanks! Zypper is a SUSE Linux tool? Is Jolla a SuSE clone? Is zypper as part in jolla store?

One of the two devices that update not found is the newest sailfish installation on a new device.

Greeting Markus

Hello,
now it works fine. I have try once again…
fist device:

second device:

and

Greeting Markus

1 Like

Had the same problem on my 2nd device, a Sony X10 Single SIM.
This command did also work on it.

edit: The above command worked and downloaded a lot of files for half an hour but after reboot, still SFOS 3.4.0.24 present. (I was typing above post while downloading…)

What can be the reason for this?

edit:
why on the second device ssu re 3.4.0.24
and on the others ssu re 4.0.1.48
only typing error or has this some meaning?

edit:
Update successful: I did the following:

devel-su
ssu re 4.0.1.48
version --dup
reboot.

then:

ssu dr customer-jolla
pkcon refresh
version --dup

While the last command was running, the phone switched off autonomous.
After power on again, while entering the access code the second time, the phone switched to the new blue background.
System info says now: SFOS 4.0.1.48 Koli
Mail accounts still present and working.
Phonebook entries OK