Update to 4.0.1.45 fails (Attempts: 1. partly downloaded[?], 2. "waiting for connection")

HARDWARE: XA2

DESCRIPTION:

Download not possible after failed update.

There are two things which are odd:

  • That the update fails in the first place (maybe because only a part of the packages were downloaded?)
  • That download is not possible anymore after the first failed update (see below)

PRECONDITIONS:

  • Uninstalled apps that are incompatible

STEPS TO REPRODUCE:

I don’t know, if it is reproduceable.

  1. Starting update procedure in settings
  2. Since download was quite fast, I assume now that only part of the update (packages) were downloaded
  3. Restarting for applying changes failed quite fast, error message tells that I shall try it later, phone rebooted

EXPECTED RESULT:

  • Retry of upgrade procedure should work

ACTUAL RESULT:

  • Now when triggereing download in the settings’ page, it hangs on “waiting for connection”. After some minutes it cancels.

Btw: No problems with internet connection. Everything else is working smoothly.

ADDITIONAL INFORMATION:

Today I tried to update in the terminal:

Changing release from 4.0.1.45 to 4.0.1.45
Your device is now in release mode!
WARNING: DBus call failed, falling back to libssu: Message recipient disconnected from message bus without replying
terminate called after throwing an instance of 'zypp::parser::ParseException'
  what():  /etc/zypp/repos.d/ssu_openrepos-Acce_release.repo: Section [openrepos-Acce]: Line 8 contains garbage (no '=' or ':/?|,\' in key)
Abortado
[root@XperiaXA2-DualSIM nemo]# vi /etc/zypp/repos.d/ssu_openrepos-Acce_release.repo
[root@XperiaXA2-DualSIM nemo]# cat /etc/zypp/repos.d/ssu_openrepos-Acce_release.repo
[openrepos-Acce]
name=openrepos-Acce
enabled=1
autorefresh=0
baseurl=plugin:ssu?repo=openrepos-Acce
type=rpm-md
gpgcheck=0
epos-Acce

I recognized that also e.g. Warehouse or pkcon refresh did not work.

I did as described in https://jolla.zendesk.com/hc/en-us/articles/360005795474-Installing-an-OS-update-fails-download-worked- Chapter “Troubleshooting” and removed all 3rd party repos. Even then pkcon refresh did not work until I rebooted.

Now ssu release 4.0.1.45 and version --dup seems to work.

I had similar issue at some point. One openrepos repository entry had corrupted in the corresponding file, but I can’t remember the file anymore… I can look it up later.

1 Like

I removed all openrepos repositories and followed the trouble shooting guide. I can confirm that a reboot is needed after all repos have been removed for a refresh to work. I’m now downloading the latest upgrade.

1 Like

It was /etc/zypp/repos.d/ssu_openrepos_*_release.repo. Can’t remember the exact file anymore. Check them out, the corruption really stands out. If it is there, that is.