Update of myaudi android-app failed

I’v installed myaudi app (version 3.20.0)on my SailfishOS device (, Sony xperia xa2 dual sim). It worked OK for a while, but than it started to ask for an update when starting it. It was quite difficult to get rid of that update popup in order to use the app. I had to hit update, than aptoide started. But in aptoide was just an even older version, so I aborted the downgrade. After repeating this procedure several times, the update-popup vanished, and I could use the app. It was quite annoying, so I looked for other ways to really upgrade to the newest version. I found it on apkmonk (version 3.21.2) and downloaded it to my phone. In the file browser I opened the apk-file and selected install from the top menu. There was a short notice, that if nothing happens, the apk is probably broken. I tried it several times, in the beginning, nothing happened, I could still start the app and get rid of the annoying update-popup. But then obviously the update “succeeded” but I was no more able to open the app. When trying to start it, it showed shortly the audi sign and than crashed. I tried to downgrade it again directly with the apk-file of the older version, but no success. I deinstalled it and tried to install it again … no success. I suppose, that there is something broken in the apk-database, but I’m not experienced enough with Sailfish and alien-dalvik to dive in deeper.
Any suggestion who to proceed? Is there a possibility to mend the apk-database?
Thanks a lot for any help

Welcome the forum. Do you have many Android .apk installed or would it be a bit much to re-install them all?

No it would be no problem, just six android apps. But four of them I do really need.

I guess aspergerguy is referring to this post?
But this I see only as the last resort. So maybe better wait for him to answer.

Same problem here with “myaudi” for two months now… I upgraded in Aurora store and now the app is not starting anymore…
I have not tried to reinstall alien-dalvik yet… Maybe that would help…

Unfortunately after trying upon two XA2 one with signature spoofing and another with Play Store I have to conclude there is no solution here as current version of MyAudi requires a higher version of Android than utilised by Sailfish. Upon launching older version app. hangs upon “App update available” as you found out. I would also expect that latest version expects phone GPS to be working to reconcile location with charging station, but maybe wrong here.

Hello aspergerguy,

thanks for your effort. What I don’t understand: in the description of the newest app on playstore, it says, that Android 8 is required an android 10 is targeted (what ever that means). So it should work with SailfishOS!?
But even if not, it would already be OK, when I just get the old version up running again. Could you give me some advise for getting it installed again?
What do you mean with “latest version expects phone GPS to be working”. It works and other android-apps (here maps) have no problem in accessing it (even if it lasts for ages to get the first lock).

Managed eventually to install de.myaudi.mobile.assistant_217881.apk (102.5MB) upon XA2 running with Signature Spoofing with new log-in screen. I am sure days are numbered upon Sailfish OS as latest VW WeConnect ID.app detects that XA2 “rooted device” and functions will be limited.

This is a very old version (3.10.1, the actual is 3.21.2 which is much smaller in size, about 30 MB). And yes, the old versions install correctly. But then you are stuck with the update-notice :unamused:
So no chance to get the new one up an running?

I made some more tests and installed different versions 3.20.0, 3.21.0, 3.21.1. Version 3.20.0 installs correctly and starts. It shows the update notice, but with some effort, it is possible to get rid of it (klicking update now and go back to the myaudi app several times). But after the login there is an error notice. I suppose, that there is a new api for the app, so that the old app is no more able to log in. When updating to the newer versions the app shortly show the audi-sign and than crashes. Lokking in journalctl I see:

Nov 10 12:36:29 Sailfish invoker[8278]: WARNING: An inactive plugin is misbehaving - tried to show a window!
Nov 10 12:36:29 Sailfish invoker[8278]: WARNING: requestActivate() called for  QQuickView(0x2f2a40)  which has Qt::WindowDoesNotAcceptFocus set.
Nov 10 12:36:30 Sailfish kernel: binder: 25017:25035 refcount change on invalid ref 11
Nov 10 12:36:30 Sailfish kernel: binder: undelivered transaction 4389121
Nov 10 12:36:30 Sailfish kernel: binder_alloc: 25017: binder_alloc_buf, no vma
Nov 10 12:36:30 Sailfish kernel: binder: 12516:12958 --> 25017:0 transaction failed 29189/-3, size 108-0 line 2259
Nov 10 12:36:30 Sailfish kernel: binder: undelivered transaction 4389114
Nov 10 12:36:32 Sailfish kernel: PMI: smblib_get_apsd_result: APSD not done yet.

Is there any hope to get it running, to deal with this errors?

Yesterday there was an update of MyAudi App.
Now the App works again for me…

yes, for me too :slight_smile: . Hopefully it last a bit longer.