Update by flashing xa2

hi ,

I could not update my OS for some time (I believe due ‘stop version’ and some packages not allowing it).
After couple of months I decided to try and did follow this page:

unfortunately when I keep “volume up” and connect to cable, led goes blue for some time but when I run script (flash.sh) I get that:

Flash utility v1.2
Detected Linux
Searching device to flash…

even fastboot is showing device for short time only, anything to try to reinstal system?

1 Like

It has often been reported to be solved by trying other cables and/or other USB ports, even USB hubs sometimes.

1 Like

Unfortunately, it happens with all USB ports and cables on my linux laptop. No problem with my linux desktop PC.

an USB-Hub might help

Please try using an USB hub with a ‘USB 2 only’ socket (white plastic in the jack, not blue). I found this as the only working way if computer has only USB 3 sockets (modern computers younger than 5 or 7 years)

The blue LED is the correct mode.

There is a better installation guide than that. This one: Installing Sailfish X on XA2 using Windows - Jolla

There is a world of difference between a data cable and a power cable and this is usually the problem. All cheap cables are power only.

Then you need the bluemode fastboot driver. As far as I know, the one in the package still works. Do you have Sony sa0114 in your Device Manager?

Did you flash Android 9 OK? You have to boot into the setup screens I believe.

In spite of the obstacles you’re coming across, it’s a good idea to reflash. I had problems on my XA2 which I believe would have gone away if I had. Then again, Dropbox is now broken but it might have been restoring my XA2 backup to my 10iii.

Could be a multitude of underlying reasons.

I recently underwent the same process, here are my notes.


hi all, thank you for replies.
I am using Ubuntu so I did not try windows yet. Cable is fine for sure data as I managed to copy some files to the phone using it, I also do not remember having any issues on this laptop and likely same cable when I installed Ubuntu touch on other device.
I will try to find any hub as indeed all usb on both laptops I have with usb 3 (I do not recall on which one I installed Sailfish X in first place actually) :confused:
Will update this thread if I try with hub

@ohnonot , I missed your reply, will try this out as well of course.

1 Like

I manage to flash using old usb hub.
glad I still have one…, will keep @ohnonot 's instructions for future in case some day hardware is not in place to rescue … I hope this can be solved by Jolla actually some day, we have usb 3 on market for around decade now (so likely same time as Jolla has Sailfish ?) I think I had no problems with Ubuntu Touch using usb 3 anymore…

This is not Jolla’s problem to solve.
It is Google (Android fastboot) and/or Sony that is responsible for this issue.


fair enough. thank you all for your support.

1 Like