Unlock bootloader Xperia XA2

Good evening everyone,
I would need your advice and help please.
I bought, some time ago, a new Xperia XA2, today I tried to unlock the bootloader, but if I do * # * # 7378423 # * # * and enter the menu, under “Rooting status”, I find written: "Bootloader unlock allowed : No ", and in fact the unlocking of the bootloader is not successful.
How could I do?
Thank you all!

Possibly using qUnlock S1 Unlock Tool but you have to pay to get server access, see this resource:

https://forum.xda-developers.com/t/bootloader-unlock-allowed-no-to-yes-is-now-finally-possible.4044091/

As in UK have purchased from here in the past:

Whilst I have managed to achieve Bootloader unlock allow = YES upon two network SIM locked Xperias previously showing NO, it appears that it has worked for some users in your position.
https://talk.maemo.org/showthread.php?t=101100

2 Likes

Hi Adrian,
and thank you very much for the reply!
Since the phone is new, even if no longer under warranty, I’ll think about making the purchase you recommended.
But what exactly does that block depend on?

From a UK perspective this was applied by Sony at the request of network providers O2 & Vodafone, from their perspective to ensure manufacturer’s firmware used upon their network; some UK networks provide factory unlocked devices to monthly contract users and not for Pay As You Go ones. Both my devices were acquired secondhand and after purchasing an unlock code on one which failed, would have had to waste another of remaining tries out of a total of (5) to take a video to try to get money back. If you have run out of remaining attempts, qUnlock S1 remains the only way of network unlocking and in my case it was a bonus to find that bootloader unlock had been also allowed.

3 Likes

In the end I bought the qUnlock S1, but nothing to do, perhaps because the sim lock was already unlocked, in fact with the Italian sim it worked perfectly.
Patience…
Thank you very much for your patience and suggestions! :smiley:

Thanks for posting the results for the benefit of others in your situation and sorry that it didn’t work out for you. The Sailfish voyage seems turbulent at times.