Unable to use Dual SIM in Xperia X, F5122

REPRODUCIBILITY (% or how often): Always
BUILD ID = OS VERSION (Settings > About product): 4.0.1.48
HARDWARE (XA2, Xperia 10…): Xperia 5122
UI LANGUAGE: English
REGRESSION: (compared to previous public release: Yes, No, ?):
Unknown

DESCRIPTION:

Dual SIM functionality not working.

SIM A - BOOST - Local in Australia
SIM B - AIS - Roaming from Thailand

All SIMS work in (a) another phone and (b) either slot in theXperia when the other slot is empty.

The phone always identifies the SIM correctly in both slots.
When both slots have a SIM card, only one SIM is working.

Examples.

SIM1 (AIS) + SIM2 (null) --> AIS connects
SIM1 (BOOST) + SIM2 (null) --> BOOST connects
SIM1 (null) + SIM2 (BOOST) --> BOOST connects
etc…

SIM1 (AIS) + SIM2 (BOOST) --> BOOST connects
SIM1 (BOOST) + SIM2 (AIS) --> BOOST connects

A bit dodgy and useless. I have this phone because Dual SIM is required functionality for me.

PRECONDITIONS:

None

STEPS TO REPRODUCE:

  1. Install two SIMS, one roaming and one local
  2. Start phone

EXPECTED RESULT:

Two active SIMS

ACTUAL RESULT:

Searching for network indefinitely

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

I believe this was working in the previous 4.x release, and worked fine on all the 3.x releases.

What do you mean with

Could it just be that in your region 3G/2G coverage went out?
Afaik the X can only have one SIM in 4G and keeps the other on 3G/2G.
That would explain why the SIMs work both when only one inside. But not both at the same time. To test you might try to limit the possible technology to 2g/3g in settings- mobile network - network mode and check connectivity/coverage.

Also selected ‘mobile internet’ sim card has preference for 4g access.

Yes.

But this does not seem to be the limiting problem here.
And would also not explain

where I’d say the local SIM just connects faster.

It makes no difference whether “Peferred 3G” or “Preferred 4G” is selected. BOOST will join whatever I set. I usually have settings “Prefer 4G”

It makes no difference whether “Roaming” is specified, which I think is data specific, but anyway …

Network search is “Automatic” but manual search comes up empty for AIS, whereas when only the AIS SIM is inserted, 3 networks are available.

Yes, the local SIM connects faster for obvious reasons. Obviously I needed to exclude the SIM readers as the point of failure.

It makes no difference what the 3G/4G preferences are set at for AIS. There are only 4 combinations and I tried them all.

I should add here that I have a LEBARA SIM from Denmark, which exhibits the same behaviour, so it’s not AIS specific.

I only had the first released version of 4.x installed for a very short amount of time before the current version was released, and I wasn’t using either SIM at the time as my local SIM for the country I was in is in another phone, so I did not really notice. It’s always worked fine in 3.x

Yes, I carry 3 SIMS because I travel a lot. You can now imagine that my life is a miserable mess at the moment as my travel options are severely curtailed!

I bought a second hand one and upgraded to 3.4 - didn’t like. I upgraded to 4.x and also didn’t like - too many things not working. Why did you upgrade? Now if you need it working perhaps you should downgrade?

on my daily phone I have 3.3.0.16. and I am sure I will wait for a while before moving forward