Tracking Android Apps under SFOS

Hello, I am new to the subject. I wanted to ask if I use Android apps in SFOS, do they track too? Does Google get any information from me when I use Android apps in SFOS?

1 Like

If you are running apps that contain trackers, they will track you. If you install apps from e.g. F-Droid, they will not track you, for apps from Google Store via Aurora you can see in the store if they contain trackers. However, as long as you do not install GApps, they will be no baseline tracking for Google, and the Android Apps won’t be able to access the Sailfish part of your data, only the part within the Android Runtime

5 Likes

Thank you dir the information

there is an app called “warden” on github. with it you can remove trackers from installed apps on android. i have not tried it on sfos, maybe it works, too.

1 Like

For trackerscan i use ClassyShark3xodus from F-Droid and i hope also that my raspberry Pi-Hole save me a little bit.

thanks my issue has been fixed.

did you try warden under sfos? does it work? (nuking trackers is under “lab”)

No, if i deactivated one tracker the response is: “Failed: No root”

-volker-

1 Like

thanks for the information.

[quote=“alexsunny123, post:9, topic:6383, full:true”]

[quote=“alexsunny123, post:6, topic:6383”]

thanks alot.

Not true. Giving access to Contacts in Android gives them access to SFOS Contacts, for example.
There used to be a switch to deny Android apps any access in alien-dalvik 4.4, but now it’s gone.

Just to follow up on the above, the Warden app is no longer on fdroid or Aurora and the github page shows no activity in the last 12 months: GitHub - whyorean/Warden: Android app management utility. Fdroid has another one called Tracker Control but the settings>options tab does nothing and it seems not to work.

Agreed, Android apps can also access and startup and pass data to Sailfish apps without restriction as well, see Native Browser Malware/Virus

have you tried it under sfos? does it work?
in lineage it is fantastic.

the feature under lab still works great with aosp roms

Probably only where Jolla deliberately mapped across an Android system call like this.