Torrent application

hello, just wanted to ask if there is a torrent application for sailfish i can actually use without having to rely on the android runtime

on the jolla one i was using clutch but now seems it’s not installable anymore due to some missing libraries

any hint?

just to be clear, i’ve asked for an application, not for a console/terminal thing like aria2 or the transmission daemon :slight_smile:

You might want to take a look at Transmission. You have to start it from the command line, but after it’s done, there is a web GUI.

althought it’s inconvenient i have no problems in running things from the terminal, anyway i guess the app is too old as like clutch says it’s missing the libcrypt package or something like this…

Yea it seems to be kind of outdated, but AFAICT there is currenty no other option…

Tremotesf works fine for me as a transmission remote.
https://openrepos.net/content/equeim/tremotesf

1 Like

I really appreciate your input, unfortunately i’m not looking for a remote, but for a complete app.

Or you meant i can start a server locally and then manage it with tremote?

I think that was the suggestion by @rsoto, yes.

Alternatively I believe aria2 can also deal with torrents, but it’s just a CLI downloader not really a daemon.

Yeah, i get it, unfortunately i don’t know how to start a local server, so i guess i will need to use some android app…

Thank you anyway…

(Almost) completely untested, but the brave may try out this build of transmission:

https://build.merproject.org/project/monitor/home:nephros:release:transmission

I can confirm that tremotesf (the app) can connect to this daemon.

3 Likes

oh thank you, two questions

1 how should i download that?i thought with chum, but it’s actually not working with the hotfix that as just been released

2 how could i connect the daemon with tremotesf?

Ad 1.:
Yes it’s not easy as this is not in chum ATM.

One way would be to select the repro you need ( depends on your device and version), and add it like this in the terminal:

ssu ar nephros-transmission <repo url>
devel-su pkcon refresh
devel-su pkcon install transmission-daemon

Ad 2.:
In tremotesf, enter a new connection and give 127.0.0.1 as the address. That’s all.

1 Like

so considering my device is an xperia xa2, it would be something like

“ssu ar nephros-transmission Index of /obs/home:/nephros:/release:/transmission/sailfishos_chum_arm” ?

of course with the adress that the forum transform into a link…

Correct, that is for the 4.4.0.68 version in chum.

Alternatively you can download the rpms from there, but you need also the dependencies (upnpc, natpmp, libevent). The latter one is in chum proper so that’s not needed if you have chum. Ignore the debug and src rpms.

You need transmission-daemon, all the others are optional.

I was asking, cause i tried that but pkcon says there is no such package

If i install those over rpms, can i manage it on chum when it’s released?

Sorry for my ignorance, tried installing rpms manually but can’t install libnatpnp and transmission-daemon

Would you be so kind to give me the correct terminal command for my architecture (armv8)

Thank you

So assuming that’s still 32but arm, and you have all three required rpms, try this:

mkdir /tmp/rpms
cp "<all downloaded rpm files>" /tmp/rpms
devel-su pkcon install-local /tmp/rpms/*.rpm
exit

The rpm names should be

libnatpmp1-20150609-1.3.1.jolla.armv7hl.rpm
miniupnpc-2.0.20170509+master.20220930083547.4ea274d-1.1.1.jolla.armv7hl.rpm
transmission-daemon-3.0.0+git3-1.4.1.jolla.armv7hl.rpm

Ah, that’s why, i was installing libnatpmp and not libnatpmp1

Installed everything now, will do a brief check then mark as solved, thank you

Ok, everything is installed now but it’s not connecting

Maybe there’s something wrong in the configuration?

One piece is probably missing.

Try from command line:

systemctl --user daemon-reload
systemctl --user start transmission-daemon

If that works, you can then, if you like, do

systemctl --user enable transmission-daemon

this should start the daemon each time after rebooting (I think haven’t tested). But that’s probably not a good idea, because of bandwidth usage you may pay for.
Just use one of these when you want to start and stop it:

systemctl --user start transmission-daemon
systemctl --user stop transmission-daemon

That’s as far as I can support you, you will have to figure out the rest of how transmission works by yourself. The config file is found in ~/.config/transmission/settings.json (as are some other dirs, such as the torrent dir).

For the rest, read the documentation of transmission:

https://forum.transmissionbt.com/
https://trac.transmissionbt.com/wiki/WikiStart

1 Like

It is working now, and it’s exactly what i wanted

thank you for everything :slight_smile:

1 Like