Threema is not starting in 4.0.1.48

REPRODUCIBILITY (% or how often): 100%
BUILD ID = OS VERSION (Settings > About product): 4.0.1.48
HARDWARE (XA2, Xperia 10…): XA2
UI LANGUAGE: German
REGRESSION: (compared to previous public release: Yes, No, ?): ?

DESCRIPTION:

After Upgrade to 4.0.1.48 I cannot start Threema app. It justr tries to start, but after a short time Threema vanishes from display.
What can I do?
Best regards, Uwe.

PRECONDITIONS:

STEPS TO REPRODUCE:

  1. Tap on Threema
  2. Vanishes after a short time from display

EXPECTED RESULT:

ACTUAL RESULT:

ADDITIONAL INFORMATION:

(Please ALWAYS attach relevant data such as logs, screenshots, etc…)

Did you try to delete the cache by using the sailfish settings -> App tab -> select threema -> and press the delete cache button?
You should ensure to close threema before that.

Thank you for your suggestions.
In the meantime I found out, it’s not only Threema that won’t start.
After upgrading to 4.0.1.48 it seems that no android app is working until deleting and then installing again.
With Threema I have some trouble to do this, because (shame on me) I don’t have a Threema backup…
So I’m thinking of copying (saving) the Threema folders to a temporary place in file system, deleting Threema, copy back the saved folders to their original place and then install Threema again. Hope that works…
Best regards, Uwe.

Ok, if you haven’t seen it yet: there has been another thread regarding a general issue with andoid apps in SF 4. And there has been posted a solution which has helped some others having the same issue:


Maybe it helps in your case as well?
It’s worth a check, before you mess around with any manual file-operation for threema only…

Thank again.
Yes I found that too, but in my case it did not help. In the meantime I deleted and reinstalled all my android apps, which was kind of tiresome, but worked.
Only with Threema I probably lost my data…
I still have all folders from my Threema, but when reinstalling Threema one gets a new ID, and that -I think- will not work with the old data…
Best regards, Uwe.

You may find the original Threema Code in your invoice. But to restore your messages a solid data backup is the only solution I know. I backup my painfully long taking two years of messages every Saturday to my SD card. :frowning:

That sounds quite like a challenge. Maybe it is best to contact threema support as well in order to figure out if there is even a chance that this will work. I mean, if you have stored your original threema files and folders separately now, you should be able to start over again and again with different versions of the app, android configurations, manually altered files or whatever might be necessary to ‘link’ your new threema installation with the previously created files. Even the order how you execute things may be decisive. General feasibility would also depend on the existence of a passphrase and PIN. But even if you use the same passphrase, I can imagine that threema uses some additional random factors depending on time and device to create some kind of comparable hash value. All this would make it impossible to restore it this way. But I may be wrong. Only threema-support is able to give you a verified answer on this.

Right you are… :frowning:

Thanks again for your explanations. In the meantime I did a service request with Threema support. And it is how I assumed. Because of a different Threema ID when reinstalled there is no possibility to get data back.
I’m used to backups with networks I work with, but in my case I really happend to forget this… My fault… :frowning:
Now I have at least a nice and clean Threema… :wink:
Thanks again and bye bye, Uwe.