The Volla X23 (GX4) Thread

I’D like to put a big fat “DON’T TRY THIS AT HOME” banner for the time being. Given that people are also having issues flashing Rephones (which I think is a non-issue) I don’t think you should try with Gigaset GX4/pro models until we have more info. I didn’t take enough notes while doing my testing and just assumed (not a bad assumption) that pulling the USB cable was the reason for all my woes. But, if I become uncertain about what steps I took and completed, you can be sure I wouldn’t trust my own output!

either way, if the X23 is actually the pro version this also would definitely explain the partition differences sonus experienced.
But can anyone enlighten me now, the GX4 / pro can be unlocked without problems and if so, how?
Or does it require it some kind of hack to root it first?

Hi Smirftsch,
Do you mean OEM unlocking to allow for installing a custom ROM (if there is any)?

⇒ This is possible by doing the usual steps (similar for many devices). Rooting the device is not needed.

From memory, these are the steps:

  • go to Settings
    • enable Developer Settings (tap 8× on the build number)
  • go to developer settings (System → Developer)
    • enable USB Debugging
    • enable OEM unlock
  • connect computer with installed ADB
    • on phone accept debugging via this PC (I did check the option to always accept this PC.)
    • on PC, type adb devices to check for okay connection (If no device is shown, repeat above steps and now miss none.)
    • on PC, type adb reboot bootloader, then wait for the phone to reboot
    • on PC, type fastboot devices as checkup (as above with adb)
    • on PC, type fastboot flashing unlock and within 5 seconds press volume up on the phone to enable flashing any ROM (like other official Android for the exact device, or, IF YOU KNOW THIS WILL PROBABLD BRICK (→ DESTROY) YOUR DEVICE any other ROM like Sailfish OS/VollaOS/Ubuntu Touch)
  • on PC, type fastboot reboot fastboot to reboot to fastbootd (If I understood it correctly, fastbootd is more modern, but less low level compared to bootloader mode. ⇒ bootloader for OEM unlocking, fastboot for fastbootd for actual flashing)

Is this what you asked for?

3 Likes

Yes, that was exactly what I was wondering about. Not every device/manufacturer allows that you know and I couldn’t find anything in the web if and how this may work with the Gigasets.
At the current stage however it seems indeed rather risky to me to try even although there seems to be no one so far who really has tried it with the pro version or did I miss something?
Either way, thanks a lot :slight_smile:

If the GX4 and GX4Pro have different EMMC sizes, that would certainly be an issue, as I create the super partition specifically for the Pro size

The GX4 has 4GB RAM and 64GB storage whereas the Pro has 6GB and 128GB so, that seems a clear guide.

Interesting is that the rephone has the specs of the GX4 PRO where RAM and EMMC are concerned and flashing it causes no issues, aside from the fact that less of the available storage is used :wink:

I’ve just seen that there are more PROs on the market and they’re not so expensive. But, I have to admit the rephone with same RAM and storage has a much nicer display than the GX4 Pro: 2340 x 1080 Pixel vs. 1560 x 720 Pixel . That’s visible pixel artifact territory. I also didn’t like the back cover which didn’t sit properly flush with the camera, but maybe that was an issue with one device. I’m not really inclined to go buy one, but then, as @piggz would say, I suffer from OCD :slight_smile:

Based on “Load the Auth file for the device in the flash tool” in the List of SP Flash Tool errors & their solutions, the authorisation file seems to be device specific and not ROM specific.

In that forum, there are several seemingly interesting threads: 439 for error codes, 286 for unbricking how tos, …
Anyways, for the Gigaset GX4, I did not find anything that is really relevant here.

For some devices, there is a way to unbrick them:

Based on the UBports Forum, there is a professional company which seems to have the authorisation codes for some devices of the brands Gigaset and Volla.

  • listed on their homepage: Gigaset GX4 / GX290 / GX290 Plus / …, Volla X / …
  • not listed: Gigaset GX4 Plus/Pro, Volla X23

If someone does send some device to them, It would be nice to hear about the price tag for unbricking.

Was your device a GX4 or GX4 pro? In the Volla Install thread, a user unbricked a rephone by setting the device in BROM mode and using SP flash 5 to do ‘Firmware Upgrade’ instead of ‘Download’ Volla Installation guide - #23 by lispy

On the basis of Reparatur Ihres Volla-Gerät inkl.5€ Erstattung der Einsendekosten it looks like firmware install is 50 Euro.

Ok, I have a Rephone. I was also the guy posting over at UBPorts about the Phone repaircompany but I never really got in touch with them because reflashing it from the UBPorts downloaded Files from ~/.cache/ubports-installer/firmware/ helped. Also, if you try to flash it using Download and it breaks with an error, try to uncheck “userdata”. This worked for me. After that I had the Volla bootscreen but the device didn’t boot until I reflashed everything (including) userdata with Firmware Upgrade + Download". Of course you always need to force the auth on the device using mtk payload command and connecting with Vol-up/Vol-Down/Power.

2 Likes

That is good news.
Since mine is a GX4 (not Pro), I’m curious whether this helps for my device with smaller storage size.

At some other source, they hinted for not flashing the preloader partition, since this could finally brick the device. What do you think wrt. this topic?

And what operating system did you use for un-bricking the devices?

Like I said, my phone was dead and bricked, so I didn’t bother with the preloader and wiped it.
I used the Scatter and img files that were downloaded by the UBPorts installer ~/.cache/ubports-installer/firmware/.

1 Like

You don’t need an auth file, only the scatter: MT6789 da2 patching results in TypeError / Support for newer V6 / bootrom patched based devices (MT68xx/MT69xx) · Issue #758 · bkerler/mtkclient · GitHub. Could you please confirm your device and its current state?

1 Like

Ah, it was not a PRO version just the GX4. I could probably have used the ‘upgrade firmware’ path (had brom mode) but I don’t have time at the moment so I passed the device on. I’ll ask and see where they are.

I ran into a curious problem…

I had SFOS flashed on my X23 up until few days ago when I decided to flash VollaOS on it, purely out of curiosity since I don’t daily drive it due to missing Waydroid implementation.

So I dicked around VollaOS for a bit, and then decided to flash back SFOS. I did the fastboot of all 3 .img files just like before, and setup went fine…until I closed the tutorial and rebooted the device. After I type the encryption password, all I get is a spinning circle on the top half of the screen…and that’s it.

After 7th flash with various ways to ‘prepare’ the phone (flashed VollaOS, flashed Ubuntu Touch,…) I can’t get past this point at all. I have enough foresight to setup password for SSH login, and was able to pull some messages from the journalctl, some of them I found interesting:

Oct 18 21:06:43 PhoneX23 encsfa-fpd[2376]: Device /dev/sailfish/home does not exist or access denied.
Oct 18 21:06:43 PhoneX23 encsfa-fpd[2376]: Device /dev/sailfish/home does not exist or access denied

And yeah, that folder doesn’t exist (in fact, there’s no LVM volumes at all, lvs comes out empty).

[root@PhoneX23 defaultuser]# ls -alh /dev/sailfish/home
ls: /dev/sailfish/home: No such file or directory
[root@PhoneX23 defaultuser]# ls -alh /dev/sailfish/
ls: /dev/sailfish/: No such file or directory
[root@PhoneX23 defaultuser]# ls -alh /dev/mapper
total 0      
drwxr-xr-x    2 root     root         100 Oct 18 21:47 .
drwxr-xr-x   19 root     root        7.6K Oct 18 21:47 ..
crw-------    1 root     root       10, 236 Oct 18 21:47 control
brw-rw----    1 root     disk      254,   1 Oct 18 21:47 home_encrypted
lrwxrwxrwx    1 root     root           7 Oct 18 21:47 system_a -> ../dm-0

And of course, journalctl is spammed with messages like these

Oct 18 21:56:12 PhoneX23 kernel: [ccci1/cif]total cnt=2075;rxq0 isr_cnt=6;rxq1 isr_cnt=67;rxq2 isr_cnt=0;rxq3 isr_cnt=0;rxq4 isr_cnt=1486;rxq5 isr_cnt=508;rxq6 isr_cnt=8;rxq7 isr_cnt=0;rxq8 isr_cnt=0;rxq9 isr_cnt=0;rxq10 isr_cnt=0;rxq11 isr_cnt=0;rxq12 isr_cnt=0;rxq13 isr_cnt=0;rxq14 isr_cnt=0;rxq15 isr_cnt=1;rxq16 isr_cnt=0;rxq17 isr_cnt=0;rxq18 isr_cnt=0;rxq19 isr_cnt=0;rxq20 isr_cnt=0;rxq21 isr_cnt=0;rxq22 isr_cnt=0;rxq23 isr_cnt=0;
Oct 18 21:56:12 PhoneX23 ofonod[2270]: Power request failed: OPERATION_NOT_ALLOWED
Oct 18 21:56:13 PhoneX23 ofonod[2270]: Power request failed: OPERATION_NOT_ALLOWED
Oct 18 21:56:13 PhoneX23 kernel: [wdk-c] cpu=0 o_k=0 lbit=0x1 cbit=0xff,fe,7,1,662076693,ff,0,0,0,0,[526343015792,15000000] 14
Oct 18 21:56:13 PhoneX23 kernel: [wdk-c] cpu=7 o_k=7 lbit=0x81 cbit=0xff,7e,7,1,662076693,ff,0,0,0,0,[526420524331,14922492] 14
Oct 18 21:56:13 PhoneX23 kernel: [wdk-c] cpu=6 o_k=6 lbit=0xc1 cbit=0xff,3e,7,1,662076693,ff,0,0,0,0,[526420556639,14922458] 14
Oct 18 21:56:13 PhoneX23 kernel: [wdk-c] cpu=4 o_k=4 lbit=0xd1 cbit=0xff,2e,7,1,662076693,ff,0,0,0,0,[526420579792,14922435] 14
Oct 18 21:56:13 PhoneX23 kernel: [wdk-c] cpu=1 o_k=1 lbit=0xd3 cbit=0xff,2c,7,1,662076693,ff,0,0,0,0,[526420587716,14922427] 14
Oct 18 21:56:13 PhoneX23 kernel: [wdk-c] cpu=2 o_k=2 lbit=0xd7 cbit=0xff,28,7,1,662076693,ff,0,0,0,0,[526420613023,14922402] 14
Oct 18 21:56:13 PhoneX23 kernel: [wdk-c] cpu=3 o_k=3 lbit=0xdf cbit=0xff,20,7,1,662076693,ff,0,0,0,0,[526420645254,14922370] 14
Oct 18 21:56:13 PhoneX23 kernel: [thread:216] 2023-10-18 19:56:13.965784 UTC;android time 2023-10-18 19:56:13.965784
Oct 18 21:56:13 PhoneX23 kernel: [wdk-k] cpu=5 o_k=5 lbit=0xff cbit=0xff,0,7,1,662076693,ff,0,0,0,0,[526420657254,14922358] 14
Oct 18 21:56:14 PhoneX23 ofonod[2270]: Power request failed: OPERATION_NOT_ALLOWED
Oct 18 21:56:15 PhoneX23 ofonod[2270]: Power request failed: OPERATION_NOT_ALLOWED
Oct 18 21:56:15 PhoneX23 kernel: [name:spm&][SPM] system_bus didn't enter MCUSYS off, MCUSYS cnt is no update
Oct 18 21:56:15 PhoneX23 kernel: [name:spm&] Pending Wakeup Sources: USB suspend lock 
Oct 18 21:56:16 PhoneX23 ofonod[2270]: Power request failed: OPERATION_NOT_ALLOWED
Oct 18 21:56:16 PhoneX23 kernel: timesync host boottime 529116068337
Oct 18 21:56:16 PhoneX23 kernel: [sm5602] fg_read_soc(761): soc=1002(0x644b)
Oct 18 21:56:16 PhoneX23 kernel: [sm5602] fg_get_property(1951): sm->batt_soc: 1002, val->intval: 100
Oct 18 21:56:16 PhoneX23 kernel: [DLPT] imix_r==0, skip
Oct 18 21:56:17 PhoneX23 ofonod[2270]: Power request failed: OPERATION_NOT_ALLOWED

If anyone has any idea where to poke or what to poke to get this sucker going, I’d be grateful. Worst case scenario, I am considering getting Volla 22 instead to daily-drive that, at least until X23 gets some more love.

EDIT: Managed to stumble on what seems to be an official-ish repo for Sailfish for X23: Github

With some modifications to the flash.sh and copying boot.img from the MEGA link, I flashed it…and get the same result…

Is it possible you need to wipe the user data partition with android recovery before you re-flash sfos?

I’d get a Volla22/GS5 or rephone while you can still get them new.

Maybe. ‘lsblk’ in the SFOS shell is a fucking mess to put it lightly :smiley: I’ll try some more partition magic later on and see if that helps.
I’ll yoink the Volla22 then, since the Xperia 10 is starting to be…unusable with weak battery and RAM.

1 Like

Few weeks later, there was some spare time again. In short: Installing VollaOS on a Gigaset GX4 (the non-pro version) worked. :slight_smile:
The notes at Volla Installation guide also helped.


With the Gigaset GX4 (not PRO), these are the things which happened with the previously bricked device (bootloader was not reached, but preloader could get accessed):

  • SP Flash Tool V5 does not seem to work under Windows nor Linux, since it rejects the Scatter-loading File file.
  • SP Flash Tool V6 has worked for restoring the boot loader. Here are my steps:
    • Unplug the USB cable from Gigaset GX4 device. (almost-Volla-X23, but smaller RAM and storage)
    • Install UBPorts Installer (e.g. via snap install ubports-installer, I have 0.9.7-beta).
    • Download the VollaOS files (Select device manuallyVolla Phone X23 for Gigaset GX4 → Select → select Volla OSInstall → Wait until the zip file is extracted.)
    • Exit UBPorts Installer. (I do not know, whether it could interfere with SPFlashTool.)
    • Download and run MediaTek Smart Phone Flash Tool V6 v6.2228.00 on Ubuntu Linux (executable file: SPFlashToolV6)
    • in SPFlashToolV6: Select the Download-XML file: ~/snap/ubports-installer/<some_number>/.cache/ubports/vidofnir/firmware/unpacked/download_agent/flash.xml
    • probably not relevant:
      • insert battery + [do or do not] press vol-up & vol-down & power, then connect USB cable
      • in terminal: Now, I tried to use MTK Client (see above) with python3 mtk payload, but this failed with Status: Handshake failed, retrying... (without booting to BROM mode via all-button-pressed boot), or with TypeError: 'NoneType' object is not subscriptable within BROM mode (started via vol-up + vol-down + power). ⇒ Probably this step is not relevant.
    • Remove battery and unplug USB cable from device
    • in SPFlashToolV6: I de-selected the checkboxes of preloader and preloader_backup, since breaking these would probably fully brick the device. This forced the Download Only mode.
    • Insert battery and USB cable. If the device does not start automatically, press the power button.
      ⇒ My device now cycled between black screen and Volla logo. For about a second in the end of the black screen phase, it is visible at the computer as USB device:
      MediaTek Inc. MT65xx Preloader (Yes, it is not a MT65xx, but a MT67xx device.) The ID is 0e8d:2000.
    • in SPFlashToolV6: Click onto Download to start flashing.
    • Wait until flashing is done. It fails with ":warning: error_msg:"
    • The device does not reach normal OS, but can be rebooted to fastboot mode or bootloader.
    • Reboot the device to bootloader.
    • Use UBPorts Installer to install your OS.

Since last time I did something wrong when installing VollaOS, this time I first tried to install Ubuntu Touch. On the first glance, this OS seems to work without any problems after the installation.

Then, I started UBPorts Installer again, connected the device, rebooted to Bootloader (Fastboot menu), and flashed VollaOS. This also seems to work without any problems.

Thank you for your stories. They helped a lot. :slight_smile:

4 Likes

New build available at Jobs · sailfishos-porters-ci / halium-vidofnir-ci · GitLab complete with kernel, boot and vendor_boot images.

4 Likes