The Volla 22 (Gigaset GS5) Thread

With and without usb cable plugged in. Bricked !?!

Disconnecting the battery and reconnecting it half a minute later may bring the phone back to life.

Thanks I already tried. I did send it to prorepair… If I get it back I’ll try to flash UT and then Sailfish. No VollaOS again. Let’s see. I have a couple of Sailfish phones.

Hopefully they don’t flash it with Android 12…

They will. They did flash it with Android 12 last time I did let repair the damaged display (for free - nice). I have had Sailfish on it. It came back with Android 12. I asked them why and if I could get a stock rom Android 11. Answer “because of security” reason they do factory reset. Android 11 is not available. That’s my dilemma.

i am very sorry for that. Try Volla Installation guide - #17 by poetaster
This helped @lispy and me.
After that i had volla 11 on the phone. sim-card detection was broken. came back with volla 12 :cold_sweat:

BUT i have to say:
i tried 3 times to install sfos, but it will not working flawless at the moment. Can ´t say why!

My other rephone works fine. Flashed from rephone android 11 in february. You know the sim trick? …in settings “pin-code” enter your pin - do not hit enter and reboot imidiatley. Maybe 2 or 3 times. Works for me pretty good.

this workaround is sfos specific, isn 't it? I had this trouble with volla 11. does it work with volla 11 too?

Yes Sfos. I don’t know how about VollaOS.

How to remove weather in terminal? I use german weather thats better for me. Long press deinstall does not work.

pkcon remove sailfish-weather

:+1::relaxed: thanks. Meecast is fine, too.

I have installed SFOS on GS5 successfully and everything is working fine (apart from few issues already mentioned that are not serious for me, apart from BLE maybe). Thanks @piggz .

However, I did not properly wipe the data so ended up with small storage space. Finally I decided to reflash. So I put the phone into recovery mode and realized that I have UBports recovery on the phone (I did install SFOS over original android without going through VollaOS). It complained about not being able to mount /dev/block/volmgr/public, but otherwise seemed working. I did “factory reset/data wipe” offered by this recovery (seemed successful, but complained about /metadata/ota not being present). Then I proceeded to fastboot and used which gave this output:


fastboot found, proceeding.

Be aware, the flashing process might take up to 10 minutes.
The screen is expected to go black. This is fine, flashing continues.

product: k69v1_64
Sending ‘boot_a’ (32768 KB) OKAY [ 0.969s]
Writing ‘boot_a’ OKAY [ 0.437s]
Finished. Total time: 1.408s
terminate called after throwing an instance of ‘std::out_of_range’
what(): basic_string::compare: __pos (which is 464) > this->size() (which is 0) line 38: 1202307 Aborted (core dumped) fastboot flash super super.img
flash super error

I realized there are two fastboots actually. One in the initial boot menu and one inside the UBports recovery, but both produce the same results. I did the procedure many times with/without rebooting before flashing.
After this I tried booting the phone normally and realized I still have fully functioning SFOS, so evidently the data wipe did not happen.

The question is, what should I do now? I guess the problem with flashing is that the data were not wiped. So should I try installing some other recovery like TWRP (does anybody recommend some specific version?) and do the wipe with that?

Thanks for any hints.

1 Like

IIRC flashing super is a single partition, holding images for system, vendor and some others. Flashing it is only possible entirely in fastboot mode, but recovery can have a fastbootd mode that can mount it and ‘flash’ each independently.
If the script just flashes super.img, the two modes are just the same.
However, is the fasboot command shipped with those scripts or is it using one from your host? Maybe update the android sdk tools if the latter.
Also, it is never a zero chance to blame it on the cable, which may in itself interact with the fastboot driver which is very… picky

I went back to my Xperia 10 II as daily driver for now and thought I’d give ubuntu touch another look. Interestingly, it shows the same high load as SFOS (system load of 25+ when idle). So it seems like a hardware-specific thing. Would be interesting though if this is also the case when the phone runs Android.

1 Like

Thanks so very much. You just saved me hours of headache xD

Ok, quick one, is there an uptodate, proven install guide for Waydroid on the Rephone (Volla 22/GS5)? I installed some stuff from Chum as mentioned in another thread but I am clueless how to fix the startup session that seems to run into a timeout…

hmm… appart from re-reading the whole thread…
But did you do this:? The Volla 22 (Gigaset GS5) Thread - #374 by ric9k

1 Like

Are there any news about flashing a rephone with Android 12 yet?

This is how I got the Waydroid to work on Volla Phone 22:

  1. Install chum
  2. Install needed packages through terminal (either on terminal app or SSH):

devel-su (to switch to root)
zypper install waydroid waydroid-gbinder-config-hybris waydroid-runner

  1. Go to /etc/gbinder.d and edit the anbox-hybris.conf file to contain following:
/dev/anbox-binder = aidl3
/dev/anbox-vndbinder = aidl3
/dev/anbox-hwbinder = hidl

/dev/anbox-binder = aidl3
/dev/anbox-vndbinder = aidl3
/dev/anbox-hwbinder = hidl
  1. Then run Waydroid init to download the image:

waydroid init

  1. Once it’s downloaded, run Waydroid from the menu and cross your fingers.