The Volla 22 (Gigaset GS5) Thread

No, I don’t think, that you have overseen something. I haven’t seen an explanation why there has been left just half of the size for the running system. Anyway I accepted that, because together with my SD-Card for me it’s enough space.
My guess is, that some stuff is needed for recovery system and android blobs. if you look at the partition layout, you see, that all the space is there but used for different things:

[root@Phone22 home]# lsblk
loop0 7:0 0 448,4M 1 loop /android/apex/
loop1 7:8 0 392,9M 1 loop /android/vendor
loop2 7:16 0 58,6G 0 loop
└─home_encrypted 253:1 0 58,6G 0 crypt /home
nbd0 43:0 0 0B 0 disk
nbd1 43:32 0 0B 0 disk
nbd2 43:64 0 0B 0 disk
nbd3 43:96 0 0B 0 disk
nbd4 43:128 0 0B 0 disk
nbd5 43:160 0 0B 0 disk
nbd6 43:192 0 0B 0 disk
nbd7 43:224 0 0B 0 disk
mmcblk0 179:0 0 116,5G 0 disk
├─mmcblk0p1 179:1 0 3M 0 part
├─mmcblk0p2 179:2 0 512K 0 part
├─mmcblk0p3 179:3 0 512K 0 part
├─mmcblk0p4 179:4 0 20M 0 part
├─mmcblk0p5 179:5 0 1M 0 part
├─mmcblk0p6 179:6 0 8M 0 part
├─mmcblk0p7 179:7 0 8M 0 part
├─mmcblk0p8 179:8 0 8M 0 part
├─mmcblk0p9 179:9 0 8M 0 part
├─mmcblk0p10 179:10 0 8M 0 part
├─mmcblk0p11 179:11 0 8M 0 part
├─mmcblk0p12 179:12 0 22,6M 0 part /metadata
├─mmcblk0p13 179:13 0 32M 0 part
├─mmcblk0p14 179:14 0 32M 0 part /mnt/vendor/nvcfg
├─mmcblk0p15 179:15 0 64M 0 part /mnt/vendor/nvdata
├─mmcblk0p16 179:16 0 48M 0 part /mnt/vendor/persist
├─mmcblk0p17 179:17 0 8M 0 part /mnt/vendor/protect_f
├─mmcblk0p18 179:18 0 8,4M 0 part /mnt/vendor/protect_s
├─mmcblk0p19 179:19 0 8M 1 part
├─mmcblk0p20 179:20 0 128M 1 part
├─mmcblk0p21 179:21 0 1M 1 part
├─mmcblk0p22 179:22 0 6M 1 part
├─mmcblk0p23 179:23 0 1M 1 part
├─mmcblk0p24 179:24 0 16M 1 part
├─mmcblk0p25 179:25 0 2M 1 part
├─mmcblk0p26 179:26 0 32M 1 part
├─mmcblk0p27 179:27 0 64M 1 part
├─mmcblk0p28 179:28 0 8M 1 part
├─mmcblk0p29 179:29 0 6M 1 part
├─mmcblk0p30 179:30 0 2M 1 part
├─mmcblk0p31 179:31 0 26M 1 part
├─mmcblk0p32 259:0 0 64M 1 part
├─mmcblk0p33 259:1 0 12M 1 part
├─mmcblk0p34 259:2 0 128M 0 part
├─mmcblk0p35 259:3 0 1M 0 part
├─mmcblk0p36 259:4 0 6M 0 part
├─mmcblk0p37 259:5 0 1M 0 part
├─mmcblk0p38 259:6 0 16M 0 part
├─mmcblk0p39 259:7 0 2M 0 part
├─mmcblk0p40 259:8 0 32M 0 part
├─mmcblk0p41 259:9 0 64M 0 part
├─mmcblk0p42 259:10 0 8M 0 part
├─mmcblk0p43 259:11 0 6M 0 part
├─mmcblk0p44 259:12 0 8G 0 part
│ └─system_a 253:0 0 7,8G 0 dm /android/vendor/bin/vndservicemanager
│ /
├─mmcblk0p45 259:13 0 107,5G 0 part /android/cache
├─mmcblk0p46 259:14 0 43M 0 part
└─mmcblk0p47 259:15 0 16M 0 part
mmcblk0boot0 179:32 0 4M 1 disk
mmcblk0boot1 179:64 0 4M 1 disk
mmcblk0rpmb 179:96 0 16M 0 disk
mmcblk1 179:128 0 119,1G 0 disk
└─mmcblk1p1 179:129 0 119,1G 0 part /run/media/defaultuser/86f16387-82ae-48ab-9b14-c834d4c286e8
zram0 254:0 0 3G 0 disk [SWAP]
nbd8 43:256 0 0B 0 disk
nbd9 43:288 0 0B 0 disk
nbd10 43:320 0 0B 0 disk
nbd11 43:352 0 0B 0 disk
nbd12 43:384 0 0B 0 disk
nbd13 43:416 0 0B 0 disk
nbd14 43:448 0 0B 0 disk
nbd15 43:480 0 0B 0 disk

If you are looking at mmcblk0p44 and mmcblk0p45 These should be the relevant partitions. So there is all together 128GB (119 GiB) space. 8GB mmcblk0p44 is for root partition. The rest mmcblk0p44 is for

  • /android/cache
  • /android/data
  • /userdata

In /userdata there is the container for the encrypted home partition (home.img).
Why it has just the given size, I don’t know. Maybe it has to do with the encryption, so there is always enough cache. In the end you have to ask @piggz or someone who is fitter with all this stuff. I’m just a user.


A very knowledgeable user though thanks to which I now know I haven’t missed anything obvious. :slight_smile:


HAH. Just a user who happens to know what a block device is.

A well, yes OK I’m an advanced user :flushed:. Still no developer :innocent:

1 Like

I can’t get this working on a Rephone. It doesn’t ask for a PIN after boot and when I open the settings and insert a PIN, I can press the checkmark and nothing happens. I only can press the cross and the SIM isn’t registered (it is called “Unbekannt” which means something like “unknown”). Reboot doesn’t lead to askig for PIN either.

Ah, I see what I did wrong:
I had to disable the SIM card and in the PIN section activate it after reboot.

1 Like

Thanks for clarifying! There seem to be two different conditions. ONCE you have the card and pin mechanism working, subsequent reboots seem fine with just toggling on and off. But, as I just had after flashing, initially you need to do what you’ve described.

1 Like

Heh. Ok, so back to the drawing board. Having used the same method as @jauri.gagarin.II on the reflash, I tried the usual dance I do on the daily GS5 and it DID NOT work. Till the third try. I’m going to have to start a thread for this.

Oh, you’re gonna challenge the famous “GPS stopped working” thread!

1 Like

Hmmm, Wifi is and stays the main annoyance on my rephone. There are not only the already stated problems, ehich got somewhat better after the last reflash. On Top I can see a lot of inconsistent behaviour. For example when I turn on Wifi, The phone always asks, what network I want to connect. Even so it already conncts to my home Wifi in the background. Or quite often when I turn WLan off the button in the top menue stays activated. But WLan is off.

The biggest impact is power consumption, when WLan is on. It eats my battery alive. The whole device has capabilities to survive two days easily without charging. But with Wifi on, it only lasts one day until I have to put it on the charger. I have that under control using situations app, which turns off Wifi, when the screen is off and turns it on again, when screen is on or the charger is connected.


anyone tested vpn on 0.21 update? (Mullvad VPN)
working or not…?

I only connect to my FritzBox via VPN. No problems so far.

I was just comparing this with the GS5 since they have a number of different odd behaviors. Both drain on wifi. But the GS5 doesn’t display this choose the network issue. We had noticed that they seem to pick different interfaces (wlan0 vs. wlan1). I’m guessing that the solution is something like disabling the extra interfaces?

Ah, ok. I’ve been doing this ‘by’ hand. This is the situations app from the jolla store? In any case, With moderate (1 hour active with minimal network use) I had managed to get over 5 days out of the GS5.

I load the open vpn config from mullvad…
connect error :frowning:

Hello Meistro Piggz

update to 0.24?

1 Like

@piggz thank you very much for this port which is running very good on my Rephone.
I am still in the process of setting everything up. So I’d like to ask, before I have to do it again :wink: Is there a reason why the used/free space seems to be only half of the capacity of the available 128GB?

1 Like

No It is the version from here:

I don’t know yet, how long battery lasts with situations. I have that configured just since the day before yesterday. But judging from the powerconsumption so far, the 5 days with VERY moderate use seem to be realistic.

Regarding the wlan interfaces, I don’t know if it is really that trivial to deactivate one interface. I’m too much user for that. I hope that @piggz can deliver some more information or maybe even a solution. The question is, why are there two interfaces. Are there really two Wifi modules build in???

1 Like

Is it ok to go for 0.24?

@piggz, the volla22 is still at .21, or?

i think .21