Telegram for android >6.2 voice messages silent

REPRODUCIBILITY (% or how often) every time
HARDWARE (Jolla1, Tablet, XA2,…): Xperia X
REGRESSION: (compared to previous public release: Yes, No, ?): No


After I updated the android version of telegram from 6.2 to 6.3 voice messages are silent. I made a downgrade to let it work again. Now I updated telegram 6.2 to 7.0 and voice messages are silent again. I contacted the Support of telegram an they don’t know this bug till now. I think it could be related to PulseAudio



  1. Install Telegram 7.0 for Android on Xperia X
  2. Try to listen to a voice message


Sound of the voice message


no sound


Help would be great :slight_smile: Thx!

1 Like

Please let me know, if this bug also exists on Xperia XA2 or Xperia 10. I love my X but I would change the device to fix this bug.

Hi. Are you still with this problem? This is happening to my xperia X too. Telegram mesaages do not play! I also contacted support but the same answer. Yesterday I flash my phone from scratch but it persists. Don’t know what’s going on. I tried to play telegram audio files manually with an ogg sailfish player and it worked fine. Any ideas?

Yes it’s still a problem for me. My uncomfortable workaround till now: I use Telegra’me now to hear voice messages in unencrypted chats. In encrypted chats I can’t hear them, because the encrypted chat is only available in the android version.

Well, I tried version 6.2 and works! It’s seems a good workaround for now.
Try Yottagram, i think it’s quite better than Telegra’me. Fernschreiber is a good one too.
Clearly the problem is due to last Sailfish Dalvik upgrade and telegram. Ogg files play ok using any Android player. Also on a Sailfish player, of course.
I’ll keep digging and searching for a solution, or at least the cause of the problem.
Please let me know if you find something.

hey, I have issues with threema and voicerecording when played it is horrible slowed down. XA2 with [] something is badly wrong with soundrecording in Adroid apps…

I’m having the same issue too, with SFOS on Sony Xperia X and Telegram for Android v8.1.2 (2432) arm-v7a, it was working until I’ve updated Telegram client last month.

I have problems with recording audio on my Xperia 10 II with SFOS

For this reason I can’t use voice messages on telegram :frowning:

Today Telegram forced me to upgrade, and consequently, voice messages don’t work any more. :frowning: I was living quite well with sticking to v6.2, but these days are over now. Now it’s really urgent to look into this!

Continuing the discussion from Telegram for android >6.2 voice messages silent:

Just FYI: I bought the Xperia 10II now and voice messages are working with this device. It seems to be a bug that on XPERIA X only.

Maybe Fernschreiber is an option for you. It worked well for me and can play voice messages. I also found another workaround to hear the audio if you not want to use a native app: if the voice messages are not from a encrypted chat, you can open them in the android filesystem to hear them. Thats not comfortable, but worked for me a while.

I can confirm these conclusion: I had a Xperia X (F5121), whitout sound in voice messages. Now, I’m testing a XA2, and Telegram have normal sound in voice messages

Thanks for the feedback! Well, it seems the problem is only on Xperia X, recently upgraded to v8 and nothing new…no audio. But v6.2 is no longer supported. Time for a change!

Makes perfect sense, Xperia X here too. However, a new phone due to this is certainly not an option, I got the X just recently as a replacement for my fairphone. Atm. I use Yottagram as a workaround to listen voice messages, and Telegram 8 for everything else. This is really just a workaround though.

It would be interesting to investigate what’s the exact issue here, whether it is SFOS or rather the android emulator, or what ever. However, I have no clue where to start debugging this. :frowning:

Same here. I use Fernschreiber to listen to voice messages but it’s not working to send audios, the other part hears nothing. So, I’m sending through Telegram anyway.
Some time ago, I’ve contacted Telegram support to find a solution to our problem but they couldn’t help.
Yesterday I installed flatpak and tried Telegram-desktop and Kotatogram, both started up, but neither allowed me to login as they are version 2.x (for ARM). Also tried installing version 3.2.5 aarch64. Installed ok, but didn’t start up.
So I think there isn’t a complete solution yet.

I have been affected by this bug too. Now I’m running Sailfish OS version 4.3 on Xperia X (F5121) and Telegram version 8.3.1 for Android. Jolla please fix this!