Suggestion for a Bicycle-Tracking App

Since Stadtradeln-Android-App using a modern Android-Api that my X Compact cant use (4.4/API19) i´m seraching for a native SailfishOS-App that can track my Bicycle tracks to Work/Home.

Any good suggestions?

OSM Scout OSM Scout | OpenRepos.net — Community Repository System

maybe Kuri | OpenRepos.net — Community Repository System

1 Like

yes, both osmscout and kuri work fine. Spotra is ancient but still works, very basic and simple.

I would recommend MeeRun if you’re 32bit but now app is close and not developed anymore (At least for SFOS). MeeRun is more but is outdated, Sporta is just ancient as @defactofactotum said. Kuri and Laufhelden aren’t that funcional but works

SFOS is missing proper sports tracking app imo

Ok, thanks for all suggestions so far.

Today in the evening will tryout Kuri, it has support for Amazfit GTS with Amazfish.

Maep is also amazing for tracking but unfortunately from February the maps don’t work cause of server problem.

Some months ago I wanted to show realtime online my track, so I used the native app “LiveTrack” , and on a wordpress the plugin “Trackserver”, and also a small home made php script to correct the provided data by LiveTrack to the format Trackserver wanted. Let me know if you want details on this setup.

Which map provider are you using that is not working in Maep anymore ?

As I read here: https://help.openstreetmap.org/questions/83146/contact-user-thedj-if-you-want-maintain-osmdb I suppose Maep used this service which is not available anymore. None of the maps choices works.

Somewhere I read that the developer of Maep would consider using OSM scout server, but the app didn’t have any newer release (comments from ~2018).

If you do know any way to make it work I would appreciate it. For me it was the best map app for mountain orienteering and I really miss it.

Here are two screenshots from my Maep application:


I know that OSM Scout is not sport tracker primarily… but what features are you missing there? :slight_smile: It allows you to record the track, display it on the map, show elevation profile and basic statistics… Tracks may be exported to gpx and uploaded to Strava or other service (not directly from the app).

2 Likes

I have my Tripometer in the Jolla store

Kuri works pretty well/fast on my X Compact with SFOS 4.4 so i go with it.

Hill shading and Hike and bike tile server from wmflabs have been discontinued since January, see Tile servers - OpenStreetMap Wiki

I’ve pushed a new version of Maep where this is mentioned. Concerning the possibility to use OSM scout server, I still need to do it :-/

Besides, OSM scout from @karry is really nice anyway !

3 Likes

@dcaliste I just realised that you are the developer of MAEP ! THANK YOU FOR YOUR APP! I can’t express how useful it was for many years to me, on mountains and in the sea! Many friends were asking me the name to find it for their android / ios phones and I was replying it is for sailfish OS with a smile in my face :wink:

As I saw in your git you made the version 1.4.13, but on chum I can find version up to 1.4.10-which I have installed. I have no idea how I could build the .rpm my own from your code or compile it, I would really appreciate if you could provide an .rpm for aarch64.

I was a bit lagging behind to update chum :-/ I’ve updated it on chum, it’s building at the moment the latest version. It should soon be available for the various OS versions and architectures.

I’m glad you like it !

Thank you for the effort Damien. Unfortunately I haven’t seen it yet in chum App or Index of /obs/sailfishos:/chum/4.4.0.58_aarch64/aarch64 . Could you please upload the .rpm on github?

Hello, sorry, I forgot to submit the package to promote it from testing to chum… It’s done now.

I saw it, thanks. Few things I noticed:
Version in “About Maep” is 1.4.10 (not .13) - May 23 2022
It still shows the tiles with “Contact [[User:TheDJ]] …” At first, when I reinstall the app, clear cache or move the map it shows the map, and after 1~2 seconds this tile appears. I checked for activated overlays, there is none. When I run it from command line I saw these lines:

Maep-Message: 23:20:35.142: Change map source to OpenCycleMap.
Maep-Message: 23:20:35.143: Creating overlay Hill shading
Maep-Message: 23:20:35.143: Change map source to Hill shading.
Maep-Message: 23:20:35.145: not a useful sized map yet for source Hill shading …
Maep-Message: 23:20:35.145: not a useful sized map yet for source Hill shading …
Maep-Message: 23:20:35.159: Class init wiki context.

Is there any chance it still tries to load the Hill Shading overlay (even I triple checked it is disabled) ?

I suppose this forum thread is not the best place to report about Maep, should I open an issue on github or make a new thread on forum.sailfishos.org ?

I figured it my own! I was looking for a file with the saved settings, and as I was reading your source code I saw you are using dconf! I run:

dconf read /apps/harbour-maep-qt/overlay-source

and returned 23. I did

dconf write /apps/harbour-maep-qt/overlay-source 0

and started the maep. Finally it works for me!